# CVE-2023-20862: Spring Security logout not clearing security context

> Spring Security fails to clear the security context during logout when using serialized sessions, allowing users to remain authenticated after logging out.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Apr 2023
- **Updated:** 5 Feb 2025
- **Also known as:** GHSA-x873-6rgc-94jc, ROOT-APP-MAVEN-CVE-2023-20862

## What is CVE-2023-20862?

CVE-2023-20862 is a medium-severity authentication bypass vulnerability in Netapp Active Iq Unified Manager, published on 19 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Spring Security, versions 5.7.x prior to 5.7.8, versions 5.8.x prior to 5.8.3, and versions 6.0.x prior to 6.0.3, the logout support does not properly clean the security context if using serialized versions. Additionally, it is not possible to explicitly save an empty security context to the HttpSessionSecurityContextRepository. This vulnerability can keep users authenticated even after they performed logout. Users of affected versions should apply the following mitigation. 5.7.x users should upgrade to 5.7.8. 5.8.x users should upgrade to 5.8.3. 6.0.x users should upgrade to 6.0.3.

Weakness: CWE-459 (Incomplete Cleanup)

## Which versions are affected by CVE-2023-20862?

6 open source packages ship an affected version, including org.springframework.security:spring-security-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | From 5.7.0 | 5.7.8 |
| `org.springframework.security:spring-security-core` | Maven | From 5.7.0 | 5.7.8 |
| `org.springframework.security:spring-security-core` | Maven | From 5.8.0 | 5.8.3 |
| `org.springframework.security:spring-security-core` | Maven | From 5.8.0 | 5.8.3 |
| `org.springframework.security:spring-security-core` | Maven | From 6.0.0 | 6.0.3 |
| `org.springframework.security:spring-security-core` | Maven | From 6.0.0 | 6.0.3 |

Products: Netapp Active Iq Unified Manager, Vmware Spring Security.

## How do I fix CVE-2023-20862?

Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 5.7.8, 5.8.3 or 6.0.3.

## Is CVE-2023-20862 being exploited?

There is no known exploitation of CVE-2023-20862 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-20862 and fix it if it is affected.

What it is: CVE-2023-20862 is a medium-severity authentication bypass vulnerability in Netapp Active Iq Unified Manager, published on 19 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-20862 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected from 5.7.0; fixed in 5.7.8
- org.springframework.security:spring-security-core (Maven): affected from 5.7.0; fixed in 5.7.8
- org.springframework.security:spring-security-core (Maven): affected from 5.8.0; fixed in 5.8.3
- org.springframework.security:spring-security-core (Maven): affected from 5.8.0; fixed in 5.8.3
- org.springframework.security:spring-security-core (Maven): affected from 6.0.0; fixed in 6.0.3
- org.springframework.security:spring-security-core (Maven): affected from 6.0.0; fixed in 6.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-20862/ (Markdown: https://insights.sbomify.com/CVE-2023-20862/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-20862
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-20862
- OSV: https://osv.dev/vulnerability/CVE-2023-20862

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-20862/
Summaries are generated and may contain mistakes; the official description above is the record.
