CVE-2023-20863 Spring Framework vulnerable to denial of service

Medium 6.5 Published Updated

Attackers can cause denial of service in applications using Spring Framework by submitting specially crafted SpEL expressions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-20863?

CVE-2023-20863 is a medium-severity denial of service vulnerability in Vmware Spring Framework, published on 13 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In spring framework versions prior to 5.2.24 release+ ,5.3.27+ and 6.0.8+ , it is possible for a user to provide a specially crafted SpEL expression that may cause a denial-of-service (DoS) condition.

Weakness: CWE-917, CWE-400

Which versions are affected by CVE-2023-20863?

6 open source packages ship an affected version, including org.springframework:spring-expression. It affects 1 product.

PackageAffectedFixed in
org.springframework:spring-expression MavenAll versions5.2.24.RELEASE
org.springframework:spring-expression MavenAll versions5.2.24.RELEASE
org.springframework:spring-expression MavenFrom 5.3.05.3.27
org.springframework:spring-expression MavenFrom 5.3.05.3.27
org.springframework:spring-expression MavenFrom 6.0.06.0.8
org.springframework:spring-expression MavenFrom 6.0.06.0.8

Products include Vmware Spring Framework.

How do I fix CVE-2023-20863?

Upgrade org.springframework:spring-expression to a fixed version for your release line: 5.2.24.RELEASE, 5.3.27 or 6.0.8.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-20863 being exploited?

There is no known exploitation of CVE-2023-20863 in the wild and no public exploit code.

All Vmware Spring Framework vulnerabilities

Sources

Also known as CLEANSTART-2026-RX06024, CLSA-2026-1781744127, DEBIAN-CVE-2023-20863, GHSA-wxqc-pxw9-g2p8, ROOT-APP-MAVEN-CVE-2023-20863, UBUNTU-CVE-2023-20863.

Is CVE-2023-20863 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free