# CVE-2023-20863: Spring Framework vulnerable to denial of service

> Attackers can cause denial of service in applications using Spring Framework by submitting specially crafted SpEL expressions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2023
- **Updated:** 7 Feb 2025
- **Also known as:** CLEANSTART-2026-RX06024, CLSA-2026-1781744127, DEBIAN-CVE-2023-20863, GHSA-wxqc-pxw9-g2p8, ROOT-APP-MAVEN-CVE-2023-20863, UBUNTU-CVE-2023-20863

## What is CVE-2023-20863?

CVE-2023-20863 is a medium-severity denial of service vulnerability in Vmware Spring Framework, published on 13 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In spring framework versions prior to 5.2.24 release+ ,5.3.27+ and 6.0.8+ , it is possible for a user to provide a specially crafted SpEL expression that may cause a denial-of-service (DoS) condition.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-20863?

6 open source packages ship an affected version, including org.springframework:spring-expression. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-expression` | Maven | All versions | 5.2.24.RELEASE |
| `org.springframework:spring-expression` | Maven | All versions | 5.2.24.RELEASE |
| `org.springframework:spring-expression` | Maven | From 5.3.0 | 5.3.27 |
| `org.springframework:spring-expression` | Maven | From 5.3.0 | 5.3.27 |
| `org.springframework:spring-expression` | Maven | From 6.0.0 | 6.0.8 |
| `org.springframework:spring-expression` | Maven | From 6.0.0 | 6.0.8 |

Products: Vmware Spring Framework.

## How do I fix CVE-2023-20863?

Upgrade org.springframework:spring-expression to a fixed version for your release line: 5.2.24.RELEASE, 5.3.27 or 6.0.8.

## Is CVE-2023-20863 being exploited?

There is no known exploitation of CVE-2023-20863 in the wild and no public exploit code.

## Other vulnerabilities in Vmware Spring Framework

- [CVE-2026-47884](https://insights.sbomify.com/CVE-2026-47884/): Spring Framework Improper Path Limitation in XsltView (critical 9.8)
- [CVE-2026-47890](https://insights.sbomify.com/CVE-2026-47890/): Spring Framework Server Sent Event stream corruption while rendering fragments (critical 9.8)
- [CVE-2026-47891](https://insights.sbomify.com/CVE-2026-47891/): Spring Framework maxInMemorySize Bypassed in Jaxb2Decoder (critical 9.8)
- [CVE-2026-47892](https://insights.sbomify.com/CVE-2026-47892/): Spring Framework Header Predicate Bypass in WebFlux Functional Endpoints (critical 9.8)
- [CVE-2026-59313](https://insights.sbomify.com/CVE-2026-59313/): Server Sent Event stream corruption in Spring MVC functional web framework (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-20863 and fix it if it is affected.

What it is: CVE-2023-20863 is a medium-severity denial of service vulnerability in Vmware Spring Framework, published on 13 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-20863 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-expression (Maven): affected all versions; fixed in 5.2.24.RELEASE
- org.springframework:spring-expression (Maven): affected all versions; fixed in 5.2.24.RELEASE
- org.springframework:spring-expression (Maven): affected from 5.3.0; fixed in 5.3.27
- org.springframework:spring-expression (Maven): affected from 5.3.0; fixed in 5.3.27
- org.springframework:spring-expression (Maven): affected from 6.0.0; fixed in 6.0.8
- org.springframework:spring-expression (Maven): affected from 6.0.0; fixed in 6.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-20863/ (Markdown: https://insights.sbomify.com/CVE-2023-20863/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-20863
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-20863
- OSV: https://osv.dev/vulnerability/CVE-2023-20863

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-20863/
Summaries are generated and may contain mistakes; the official description above is the record.
