CVE-2023-20873 Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry

Critical 9.8 Published Updated

Applications deployed to Cloud Foundry may suffer from a security bypass, requiring developers to upgrade Spring Boot.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-20873?

CVE-2023-20873 is a critical vulnerability in Spring Boot, published on 20 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.

Which versions are affected by CVE-2023-20873?

8 open source packages ship an affected version, including org.springframework.boot:spring-boot-actuator-autoconfigure. It affects 1 product.

PackageAffectedFixed in
org.springframework.boot:spring-boot-actuator-autoconfigure MavenAll versions2.5.15
org.springframework.boot:spring-boot-actuator-autoconfigure MavenAll versions2.5.15
org.springframework.boot:spring-boot-actuator-autoconfigure MavenFrom 2.6.02.6.15
org.springframework.boot:spring-boot-actuator-autoconfigure MavenFrom 2.6.02.6.15
org.springframework.boot:spring-boot-actuator-autoconfigure MavenFrom 2.7.02.7.11
org.springframework.boot:spring-boot-actuator-autoconfigure MavenFrom 2.7.02.7.11
2 more packages
org.springframework.boot:spring-boot-actuator-autoconfigure MavenFrom 3.0.03.0.6
org.springframework.boot:spring-boot-actuator-autoconfigure MavenFrom 3.0.03.0.6

Products include Vmware Spring Boot.

How do I fix CVE-2023-20873?

Upgrade org.springframework.boot:spring-boot-actuator-autoconfigure to a fixed version for your release line: 2.5.15, 2.6.15, 2.7.11 or 3.0.6.

Is CVE-2023-20873 being exploited?

There is no known exploitation of CVE-2023-20873 in the wild and no public exploit code.

Sources

Also known as GHSA-g5h3-w546-pj7f.

Is CVE-2023-20873 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free