# CVE-2023-20873: Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry

> Applications deployed to Cloud Foundry may suffer from a security bypass, requiring developers to upgrade Spring Boot.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2023
- **Updated:** 5 May 2025
- **Also known as:** GHSA-g5h3-w546-pj7f

## What is CVE-2023-20873?

CVE-2023-20873 is a critical vulnerability in Spring Boot, published on 20 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.

## Which versions are affected by CVE-2023-20873?

8 open source packages ship an affected version, including org.springframework.boot:spring-boot-actuator-autoconfigure. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.boot:spring-boot-actuator-autoconfigure` | Maven | All versions | 2.5.15 |
| `org.springframework.boot:spring-boot-actuator-autoconfigure` | Maven | All versions | 2.5.15 |
| `org.springframework.boot:spring-boot-actuator-autoconfigure` | Maven | From 2.6.0 | 2.6.15 |
| `org.springframework.boot:spring-boot-actuator-autoconfigure` | Maven | From 2.6.0 | 2.6.15 |
| `org.springframework.boot:spring-boot-actuator-autoconfigure` | Maven | From 2.7.0 | 2.7.11 |
| `org.springframework.boot:spring-boot-actuator-autoconfigure` | Maven | From 2.7.0 | 2.7.11 |
| `org.springframework.boot:spring-boot-actuator-autoconfigure` | Maven | From 3.0.0 | 3.0.6 |
| `org.springframework.boot:spring-boot-actuator-autoconfigure` | Maven | From 3.0.0 | 3.0.6 |

Products: Vmware Spring Boot.

## How do I fix CVE-2023-20873?

Upgrade org.springframework.boot:spring-boot-actuator-autoconfigure to a fixed version for your release line: 2.5.15, 2.6.15, 2.7.11 or 3.0.6.

## Is CVE-2023-20873 being exploited?

There is no known exploitation of CVE-2023-20873 in the wild and no public exploit code.

## Other vulnerabilities in Spring Boot

- [CVE-2026-40976](https://insights.sbomify.com/CVE-2026-40976/): Spring Boot's default security filter chain has no authorization rule with Actuator but without Health (critical 9.1)
- [CVE-2026-22731](https://insights.sbomify.com/CVE-2026-22731/): Authentication Bypass under Actuator Health groups paths (high 8.2)
- [CVE-2026-22733](https://insights.sbomify.com/CVE-2026-22733/): Authentication Bypass under Actuator CloudFoundry endpoints (high 8.2)
- [CVE-2022-27772](https://insights.sbomify.com/CVE-2022-27772/): Temporary Directory Hijacking to Local Privilege Escalation Vulnerability in org.springframework.boot:spring-boot (high 7.8)
- [CVE-2026-40972](https://insights.sbomify.com/CVE-2026-40972/): Spring Boot DevTools remote secret comparison is vulnerable to timing attacks (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-20873 and fix it if it is affected.

What it is: CVE-2023-20873 is a critical vulnerability in Spring Boot, published on 20 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-20873 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.boot:spring-boot-actuator-autoconfigure (Maven): affected all versions; fixed in 2.5.15
- org.springframework.boot:spring-boot-actuator-autoconfigure (Maven): affected all versions; fixed in 2.5.15
- org.springframework.boot:spring-boot-actuator-autoconfigure (Maven): affected from 2.6.0; fixed in 2.6.15
- org.springframework.boot:spring-boot-actuator-autoconfigure (Maven): affected from 2.6.0; fixed in 2.6.15
- org.springframework.boot:spring-boot-actuator-autoconfigure (Maven): affected from 2.7.0; fixed in 2.7.11
- org.springframework.boot:spring-boot-actuator-autoconfigure (Maven): affected from 2.7.0; fixed in 2.7.11
- org.springframework.boot:spring-boot-actuator-autoconfigure (Maven): affected from 3.0.0; fixed in 3.0.6
- org.springframework.boot:spring-boot-actuator-autoconfigure (Maven): affected from 3.0.0; fixed in 3.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-20873/ (Markdown: https://insights.sbomify.com/CVE-2023-20873/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-20873
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-20873
- OSV: https://osv.dev/vulnerability/CVE-2023-20873

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-20873/
Summaries are generated and may contain mistakes; the official description above is the record.
