# CVE-2023-20902: Timing attack risk in Harbor

> An attacker with network access can exploit a timing condition to create, stop, or retrieve job task information in Harbor.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2023
- **Updated:** 4 Sep 2024
- **Also known as:** BIT-harbor-2023-20902, GHSA-mq6f-5xh5-hgcf, GO-2023-2109

## What is CVE-2023-20902?

CVE-2023-20902 is a medium-severity vulnerability in Harbor Project, published on 9 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A timing condition in Harbor 2.6.x and below, Harbor 2.7.2 and below,  Harbor 2.8.2 and below, and Harbor 1.10.17 and below allows an attacker with network access to 
create jobs/stop job tasks and retrieve job task information.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2023-20902?

8 open source packages ship an affected version, including github.com/goharbor/harbor and harbor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/goharbor/harbor` | Go | All versions | 1.10.18, 2.7.3+incompatible, 2.8.3+incompatible |
| `github.com/goharbor/harbor` | Go | All versions | 1.10.18 |
| `github.com/goharbor/harbor` | Go | All versions | 1.10.18 |
| `github.com/goharbor/harbor` | Go | From 2.0.0 | 2.7.3 |
| `github.com/goharbor/harbor` | Go | From 2.0.0 | 2.7.3 |
| `github.com/goharbor/harbor` | Go | From 2.8.0 | 2.8.3 |
| `github.com/goharbor/harbor` | Go | From 2.8.0 | 2.8.3 |
| `harbor` | Bitnami | All versions | 1.10.17, 2.6.5, 2.7.3, 2.8.3 |

Products: Linuxfoundation Harbor.

## How do I fix CVE-2023-20902?

Upgrade github.com/goharbor/harbor to a fixed version for your release line: 1.10.18, 2.7.3+incompatible, 2.8.3+incompatible or 2.7.3.

## Is CVE-2023-20902 being exploited?

There is no known exploitation of CVE-2023-20902 in the wild and no public exploit code.

## Other vulnerabilities in Harbor Project

- [CVE-2026-4404](https://insights.sbomify.com/CVE-2026-4404/): Use of hard coded credentials in GoHarbor Harbor (critical 9.4)
- [CVE-2019-19023](https://insights.sbomify.com/CVE-2019-19023/): Privilege Escalation in Cloud Native Computing Foundation Harbor (high 8.8)
- [CVE-2019-19025](https://insights.sbomify.com/CVE-2019-19025/): Cross-site Request Forgery (CSRF) in Cloud Native Computing Foundation Harbor (high 8.8)
- [CVE-2017-17697](https://insights.sbomify.com/CVE-2017-17697/): Server-side request forgery in n/a (high 8.6)
- [CVE-2022-31666](https://insights.sbomify.com/CVE-2022-31666/): Harbor fails to validate user permissions while Viewing, updating and deleting Webhook policies (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-20902 and fix it if it is affected.

What it is: CVE-2023-20902 is a medium-severity vulnerability in Harbor Project, published on 9 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-20902 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/goharbor/harbor (Go): affected all versions; fixed in 1.10.18, 2.7.3+incompatible, 2.8.3+incompatible
- github.com/goharbor/harbor (Go): affected all versions; fixed in 1.10.18
- github.com/goharbor/harbor (Go): affected all versions; fixed in 1.10.18
- github.com/goharbor/harbor (Go): affected from 2.0.0; fixed in 2.7.3
- github.com/goharbor/harbor (Go): affected from 2.0.0; fixed in 2.7.3
- github.com/goharbor/harbor (Go): affected from 2.8.0; fixed in 2.8.3
- github.com/goharbor/harbor (Go): affected from 2.8.0; fixed in 2.8.3
- harbor (Bitnami): affected all versions; fixed in 1.10.17, 2.6.5, 2.7.3, 2.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-20902/ (Markdown: https://insights.sbomify.com/CVE-2023-20902/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-20902
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-20902
- OSV: https://osv.dev/vulnerability/CVE-2023-20902

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-20902/
Summaries are generated and may contain mistakes; the official description above is the record.
