# CVE-2023-2142: Nunjucks autoescape bypass leads to cross site scripting

> Attackers can bypass autoescape to inject cross-site scripting payloads via backslash characters in user-controlled parameters.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Nov 2024
- **Updated:** 27 Nov 2024
- **Also known as:** DEBIAN-CVE-2023-2142, GHSA-x77j-w7wf-fjmw, UBUNTU-CVE-2023-2142

## What is CVE-2023-2142?

CVE-2023-2142 is a medium-severity cross-site scripting vulnerability in Mozilla Nunjucks, published on 26 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Nunjucks versions prior to version 3.2.4, it was 
possible to bypass the restrictions which are provided by the autoescape
 functionality. If there are two user-controlled parameters on the same 
line used in the views, it was possible to inject cross site scripting 
payloads using the backslash \ character.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-2142?

2 open source packages ship an affected version, including nunjucks. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nunjucks` | npm | All versions | 3.2.4 |
| `nunjucks` | npm | All versions | 3.2.4 |

Products: Mozilla Nunjucks.

## How do I fix CVE-2023-2142?

Upgrade nunjucks to 3.2.4 or later.

## Is CVE-2023-2142 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2142 exists.

## Other vulnerabilities in Mozilla Nunjucks

- [CVE-2016-10547](https://insights.sbomify.com/CVE-2016-10547/): Cross-Site Scripting in nunjucks (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2142 and fix it if it is affected.

What it is: CVE-2023-2142 is a medium-severity cross-site scripting vulnerability in Mozilla Nunjucks, published on 26 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2142 exists.

Affected packages and fixed versions:
- nunjucks (npm): affected all versions; fixed in 3.2.4
- nunjucks (npm): affected all versions; fixed in 3.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2142/ (Markdown: https://insights.sbomify.com/CVE-2023-2142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2142
- OSV: https://osv.dev/vulnerability/CVE-2023-2142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2142/
Summaries are generated and may contain mistakes; the official description above is the record.
