CVE-2023-2164 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Medium 5.4 Published Updated

An attacker can execute arbitrary scripts in victim browsers via a crafted URL in the GitLab WebIDE beta feature.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-2164?

CVE-2023-2164 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 1 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting all versions starting from 15.9 before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. It was possible for an attacker to trigger a stored XSS vulnerability via user interaction with a crafted URL in the WebIDE beta.

Weakness: CWE-79

Which versions are affected by CVE-2023-2164?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.9.016.0.8, 16.1.3, 16.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-2164?

Upgrade gitlab to a fixed version for your release line: 16.0.8, 16.1.3 or 16.2.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-2164 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2164 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-2164, GHSA-4vc2-wm37-4628, UBUNTU-CVE-2023-2164.

Is CVE-2023-2164 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free