CVE-2023-2182 Privilege escalation in GitLab

Medium 6.8 Published Updated

External users can escalate to regular user privileges when OpenID Connect is enabled, requiring an upgrade to GitLab EE.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-2182?

CVE-2023-2182 is a medium-severity vulnerability in Gitlab Gitlab, published on 3 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 15.10 before 15.10.5, all versions starting from 15.11 before 15.11.1. Under certain conditions when OpenID Connect is enabled on an instance, it may allow users who are marked as 'external' to become 'regular' users thus leading to privilege escalation for those users.

Which versions are affected by CVE-2023-2182?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.10.015.10.5, 15.11.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-2182?

Upgrade gitlab to a fixed version for your release line: 15.10.5 or 15.11.1.

Is CVE-2023-2182 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2182 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-2182, GHSA-j24v-67h6-cx49.

Is CVE-2023-2182 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free