# CVE-2023-21971: Denial of service in MySQL Connectors

> High-privileged attackers can cause a complete denial of service and unauthorized data access in MySQL Connector/J via difficult-to-exploit network attacks.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Apr 2023
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-8273-q4gg-6jm9, SUSE-SU-2023:2241-1, SUSE-SU-2023:2979-1, UBUNTU-CVE-2023-21971, openSUSE-SU-2024:12927-1

## What is CVE-2023-21971?

CVE-2023-21971 is a medium-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 18 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Vulnerability in the MySQL Connectors product of Oracle MySQL (component: Connector/J).  Supported versions that are affected are 8.0.32 and prior. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Connectors.  Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Connectors as well as  unauthorized update, insert or delete access to some of MySQL Connectors accessible data and  unauthorized read access to a subset of MySQL Connectors accessible data. CVSS 3.1 Base Score 5.3 (Confidentiality, Integrity and Availability impacts).  CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:H).

## Which versions are affected by CVE-2023-21971?

It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mysql-connector-java` | openSUSE:Leap 15.4 | All versions | 8.0.32-150200.3.15.1 |
| `mysql-connector-java` | openSUSE:Leap 15.4 | All versions | 8.0.33-150200.3.18.1 |
| `mysql-connector-java` | openSUSE:Leap 15.5 | All versions | 8.0.33-150200.3.18.1 |
| `mysql-connector-java` | openSUSE:Tumbleweed | All versions | 8.0.33-2.1 |

Products: Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Snapcenter, Oracle Communications Cloud Native Core Binding Support Function, Oracle Communications Cloud Native Core Policy, Oracle Mysql Connectors.

## How do I fix CVE-2023-21971?

Apply the vendor's patch.

## Is CVE-2023-21971 being exploited?

There is no known exploitation of CVE-2023-21971 in the wild and no public exploit code.

Public exploit code:

- CVE-2023-21971 Connector/J RCE Analysis分析 (github_poc): https://github.com/Avento/CVE-2023-21971_Analysis

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-21971 and fix it if it is affected.

What it is: CVE-2023-21971 is a medium-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 18 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-21971 in the wild and no public exploit code.

Affected product: Netapp Active Iq Unified Manager. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-21971/ (Markdown: https://insights.sbomify.com/CVE-2023-21971/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-21971
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-21971
- OSV: https://osv.dev/vulnerability/CVE-2023-21971

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-21971/
Summaries are generated and may contain mistakes; the official description above is the record.
