CVE-2023-2198 Denial of service in GitLab

High 7.5 Published Updated

Attackers can cause a denial of service in GitLab by sending crafted payloads to the preview_markdown endpoint, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-2198?

CVE-2023-2198 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 7 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 8.7 before 15.10.8, all versions starting from 15.11 before 15.11.7, all versions starting from 16.0 before 16.0.2. A Regular Expression Denial of Service was possible via sending crafted payloads to the preview_markdown endpoint.

Weakness: CWE-1333

Which versions are affected by CVE-2023-2198?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.7.015.10.8, 15.11.7, 16.0.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-2198?

Upgrade gitlab to a fixed version for your release line: 15.10.8, 15.11.7 or 16.0.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-2198 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2198 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-2198, GHSA-2p9w-5q3p-g7cv, UBUNTU-CVE-2023-2198.

Is CVE-2023-2198 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free