CVE-2023-2200 Improper Encoding or Escaping of Output in GitLab

Medium 4.1 Published Updated

An attacker can inject HTML into email address fields in GitLab, potentially leading to cross-site scripting attacks and account compromise.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-2200?

CVE-2023-2200 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 13 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 7.14 before 15.11.10, all versions starting from 16.0 before 16.0.6, all versions starting from 16.1 before 16.1.1, which allows an attacker to inject HTML in an email address field.

Weakness: CWE-79, CWE-116

Which versions are affected by CVE-2023-2200?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 7.14.015.11.10, 16.0.6, 16.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-2200?

Upgrade gitlab to a fixed version for your release line: 15.11.10, 16.0.6 or 16.1.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-2200 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2200 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-2200, GHSA-w7pv-hcjh-p9w4, UBUNTU-CVE-2023-2200.

Is CVE-2023-2200 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free