CVE-2023-22084 Denial of service in MySQL Server
A high-privileged attacker can cause a complete denial of service in MySQL Server via network access.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-22084?
CVE-2023-22084 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 17 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Vulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB). Supported versions that are affected are 5.7.43 and prior, 8.0.34 and prior and 8.1.0. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).
Which versions are affected by CVE-2023-22084?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 10.4.32, 10.5.23, 10.6.16, 10.10.7, 10.11.6, 11.0.4, 11.1.3, 11.2.2 |
mariadb-min Bitnami | All versions | 10.4.32, 10.5.23, 10.6.16, 10.10.7, 10.11.6, 11.0.4, 11.1.3, 11.2.2 |
mysql-client Bitnami | All versions | 10.4.32, 10.5.23, 10.6.16, 10.10.7, 10.11.6, 11.0.4, 11.1.3, 11.2.2 |
Linux distribution packages (9)
mariadb SUSE:Enterprise Storage 7.1 | All versions | 10.5.23-150300.3.38.1 |
mariadb SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 10.4.32-150200.3.48.1 |
mariadb SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 10.5.23-150300.3.38.1 |
mariadb SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 10.5.23-150300.3.38.1 |
mariadb SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 10.4.32-150200.3.48.1 |
mariadb SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 10.5.23-150300.3.38.1 |
mariadb SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 10.4.32-150200.3.48.1 |
mariadb SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 10.5.23-150300.3.38.1 |
mariadb104 openSUSE:Leap 15.6 | All versions | 10.4.33-150100.3.8.1 |
Products include Fedoraproject Fedora, Mariadb Mariadb, Netapp Oncommand Insight, Oracle Mysql.
How do I fix CVE-2023-22084?
Upgrade mariadb to a fixed version for your release line: 10.4.32, 10.5.23, 10.6.16 or 10.10.7.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-22084 being exploited?
There is no known exploitation of CVE-2023-22084 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as ALPINE-CVE-2023-22084, AZL-31583, BIT-mariadb-2023-22084, BIT-mariadb-min-2023-22084, BIT-mysql-client-2023-22084, DEBIAN-CVE-2023-22084 and 10 more.