# CVE-2023-22102: MySQL Connectors takeover vulnerability

> An unauthenticated attacker can compromise MySQL Connectors via network access, potentially leading to takeover and impacting additional products.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Oct 2023
- **Updated:** 6 Mar 2025
- **Also known as:** AZL-31573, GHSA-m6vm-37g8-gqvh, ROOT-APP-MAVEN-CVE-2023-22102, UBUNTU-CVE-2023-22102

## What is CVE-2023-22102?

CVE-2023-22102 is a high-severity vulnerability in Netapp Oncommand Insight, published on 17 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Vulnerability in the MySQL Connectors product of Oracle MySQL (component: Connector/J).  Supported versions that are affected are 8.1.0 and prior. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise MySQL Connectors.  Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in MySQL Connectors, attacks may significantly impact additional products (scope change). Successful attacks of this vulnerability can result in takeover of MySQL Connectors. CVSS 3.1 Base Score 8.3 (Confidentiality, Integrity and Availability impacts).  CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H).

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-22102?

4 open source packages ship an affected version, including com.mysql:mysql-connector-j and mysql:mysql-connector-java. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.mysql:mysql-connector-j` | Maven | All versions | 8.2.0 |
| `com.mysql:mysql-connector-j` | Maven | All versions | 8.2.0 |
| `mysql:mysql-connector-java` | Maven | All versions to 8.0.33 | None |
| `mysql:mysql-connector-java` | Maven | All versions to 8.0.33 | None |

Products: Netapp Oncommand Insight, Oracle Mysql Connector\/J.

## How do I fix CVE-2023-22102?

Upgrade com.mysql:mysql-connector-j to 8.2.0 or later.

## Is CVE-2023-22102 being exploited?

There is no known exploitation of CVE-2023-22102 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Oncommand Insight

- [CVE-2017-5600](https://insights.sbomify.com/CVE-2017-5600/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2018-1258](https://insights.sbomify.com/CVE-2018-1258/): Spring Framework when used in combination with any versions of Spring Security contains an authorization bypass (high 8.8)
- [CVE-2020-5421](https://insights.sbomify.com/CVE-2020-5421/): RFD Protection Bypass via jsessionid (high 8.7)
- [CVE-2022-38733](https://insights.sbomify.com/CVE-2022-38733/): Auth bypass in OnCommand Insight (high 8.6)
- [CVE-2021-35583](https://insights.sbomify.com/CVE-2021-35583/): Denial of service in MySQL Server (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22102 and fix it if it is affected.

What it is: CVE-2023-22102 is a high-severity vulnerability in Netapp Oncommand Insight, published on 17 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-22102 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.mysql:mysql-connector-j (Maven): affected all versions; fixed in 8.2.0
- com.mysql:mysql-connector-j (Maven): affected all versions; fixed in 8.2.0
- mysql:mysql-connector-java (Maven): affected all versions up to 8.0.33; no fix listed
- mysql:mysql-connector-java (Maven): affected all versions up to 8.0.33; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22102/ (Markdown: https://insights.sbomify.com/CVE-2023-22102/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22102
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22102
- OSV: https://osv.dev/vulnerability/CVE-2023-22102

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22102/
Summaries are generated and may contain mistakes; the official description above is the record.
