# CVE-2023-22247: Adobe Commerce XML Injection Arbitrary file system read

> Unauthenticated attackers can exploit XML injection to read arbitrary files from the file system in Adobe Commerce.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2023
- **Updated:** 5 Mar 2025
- **Also known as:** GHSA-2444-8gj8-6fmx

## What is CVE-2023-22247?

CVE-2023-22247 is a high-severity vulnerability in Adobe Commerce, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Adobe Commerce versions 2.4.4-p2 (and earlier) and 2.4.5-p1 (and earlier) are affected by an XML Injection vulnerability that could lead to arbitrary file system read. An unauthenticated attacker can force the application to make arbitrary requests via injection of arbitrary URLs. Exploitation of this issue does not require user interaction.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2023-22247?

8 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | From 2.4.4-p1 | 2.4.4-p3 |
| `magento/community-edition` | Packagist | From 2.4.4-p1 | 2.4.4-p3 |
| `magento/community-edition` | Packagist | From 2.4.5-p1 | 2.4.5-p2 |
| `magento/community-edition` | Packagist | From 2.4.5-p1 | 2.4.5-p2 |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |

Products: Adobe Commerce, Adobe Magento Open Source.

## How do I fix CVE-2023-22247?

Upgrade magento/community-edition to a fixed version for your release line: 2.4.4-p3 or 2.4.5-p2.

## Is CVE-2023-22247 being exploited?

There is no known exploitation of CVE-2023-22247 in the wild and no public exploit code.

## Other vulnerabilities in Adobe Commerce

- [CVE-2026-75650](https://insights.sbomify.com/CVE-2026-75650/): Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine (critical 10.0, exploited in the wild)
- [CVE-2024-34102](https://insights.sbomify.com/CVE-2024-34102/): Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE) (critical 9.8, exploited in the wild)
- [CVE-2022-24086](https://insights.sbomify.com/CVE-2022-24086/): Adobe Commerce and Magento Open Source Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-48356](https://insights.sbomify.com/CVE-2026-48356/): Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type (critical 9.3, exploited in the wild)
- [CVE-2026-71362](https://insights.sbomify.com/CVE-2026-71362/): Adobe Commerce and Magento Incorrect Authorization Vulnerability (critical 9.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22247 and fix it if it is affected.

What it is: CVE-2023-22247 is a high-severity vulnerability in Adobe Commerce, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22247 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected from 2.4.4-p1; fixed in 2.4.4-p3
- magento/community-edition (Packagist): affected from 2.4.4-p1; fixed in 2.4.4-p3
- magento/community-edition (Packagist): affected from 2.4.5-p1; fixed in 2.4.5-p2
- magento/community-edition (Packagist): affected from 2.4.5-p1; fixed in 2.4.5-p2
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22247/ (Markdown: https://insights.sbomify.com/CVE-2023-22247/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22247
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22247
- OSV: https://osv.dev/vulnerability/CVE-2023-22247

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22247/
Summaries are generated and may contain mistakes; the official description above is the record.
