{"answers":{"affected":"3 open source packages ship an affected version, including pgadmin4. It affects 2 products.","exploited":"There is no known exploitation of CVE-2023-22298 in the wild and no public exploit code.","fix":"Upgrade pgadmin4 to 6.14 or later.","what":"CVE-2023-22298 is a medium-severity vulnerability in Fedoraproject Fedora, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-22298 and fix it if it is affected.\n\nWhat it is: CVE-2023-22298 is a medium-severity vulnerability in Fedoraproject Fedora, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-22298 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgadmin4 (PyPI): affected all versions; fixed in 6.14\n- pgadmin4 (PyPI): affected all versions; fixed in 6.14\n- pgadmin4 (PyPI): affected all versions; fixed in 6.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-22298/ (Markdown: https://insights.sbomify.com/CVE-2023-22298/index.md)","id":"CVE-2023-22298","markdown":"https://insights.sbomify.com/CVE-2023-22298/index.md","name":"CVE-2023-22298","record":{"aliases":["GHSA-894c-rg7f-3c62","PYSEC-2026-894","SUSE-SU-2023:1739-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL management tool","requires_auth":"none","summary":"Remote attackers can redirect users to malicious sites via crafted URLs, enabling phishing attacks against pgAdmin 4 users.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"pgadmin_4","vendor":"pgadmin"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"Open redirect vulnerability in pgAdmin 4 versions prior to v6.14 allows a remote unauthenticated attacker to redirect a user to an arbitrary web site and conduct a phishing attack by having a user to access a specially crafted URL.","ecosystems":["PyPI","SUSE:Linux Enterprise Module for Server Applications 15 SP4","SUSE:Linux Enterprise Real Time 15 SP3","openSUSE:Leap 15.4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pgAdmin 4 Open Redirect vulnerability","id":"CVE-2023-22298","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"open_redirect","year":"2023"},"n_packages":6,"n_references":5,"next":{"headline":"Command injection in UR32L","id":"CVE-2023-22299"},"packages":[{"ecosystem":"PyPI","fixed":["6.14"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":null,"source":"GHSA-894c-rg7f-3c62"},{"ecosystem":"PyPI","fixed":["6.14"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"GHSA-894c-rg7f-3c62"},{"ecosystem":"PyPI","fixed":["6.14"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"PYSEC-2026-894"},{"ecosystem":"SUSE:Linux Enterprise Module for Server Applications 15 SP4","fixed":["4.30-150300.3.6.1"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:rpm/suse/pgadmin4\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Server%20Applications%2015%20SP4","source":"SUSE-SU-2023:1739-1"},{"ecosystem":"SUSE:Linux Enterprise Real Time 15 SP3","fixed":["4.30-150300.3.6.1"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:rpm/suse/pgadmin4\u0026distro=SUSE%20Linux%20Enterprise%20Real%20Time%2015%20SP3","source":"SUSE-SU-2023:1739-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["4.30-150300.3.6.1"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:rpm/opensuse/pgadmin4\u0026distro=openSUSE%20Leap%2015.4","source":"SUSE-SU-2023:1739-1"}],"prev":{"headline":"Memory corruption in Intel(R) Server Board BMC firmware","id":"CVE-2023-22297"},"products":["pgAdmin 4"],"published":"2023-01-17","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-03","vendors":["pgAdmin Project"]},"summary":"Remote attackers can redirect users to malicious sites via crafted URLs, enabling phishing attacks against pgAdmin 4 users.","url":"https://insights.sbomify.com/CVE-2023-22298/"}