# CVE-2023-22453: Discourse vulnerable to exposure of user post counts per topic to unauthorized users

> Unauthorized users can view the number of posts a specific user made in any topic via the user profile JSON endpoint.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** BIT-discourse-2023-22453, GHSA-xx97-6494-p2rv

## What is CVE-2023-22453?

CVE-2023-22453 is a medium-severity vulnerability in Discourse Discourse, published on 5 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an option source discussion platform. Prior to version 2.8.14 on the `stable` branch and version 3.0.0.beta16 on the `beta` and `tests-passed` branches, the number of times a user posted in an arbitrary topic is exposed to unauthorized users through the `/u/username.json` endpoint. The issue is patched in version 2.8.14 and 3.0.0.beta16. There is no known workaround.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-22453?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2.8.14 |

Products: Discourse Discourse.

## How do I fix CVE-2023-22453?

Upgrade discourse to 2.8.14 or later.

## Is CVE-2023-22453 being exploited?

There is no known exploitation of CVE-2023-22453 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22453 and fix it if it is affected.

What it is: CVE-2023-22453 is a medium-severity vulnerability in Discourse Discourse, published on 5 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22453 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2.8.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22453/ (Markdown: https://insights.sbomify.com/CVE-2023-22453/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22453
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22453
- OSV: https://osv.dev/vulnerability/CVE-2023-22453

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22453/
Summaries are generated and may contain mistakes; the official description above is the record.
