# CVE-2023-22455: Discourse vulnerable to Cross-site Scripting through tag descriptions

> Attackers can inject malicious scripts via tag descriptions, leading to XSS if the default Content Security Policy is modified or disabled.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** BIT-discourse-2023-22455, GHSA-5rq6-466r-6mr9

## What is CVE-2023-22455?

CVE-2023-22455 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 5 Jan 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Discourse is an option source discussion platform. Prior to version 2.8.14 on the `stable` branch and version 3.0.0.beta16 on the `beta` and `tests-passed` branches, tag descriptions, which can be updated by moderators, can be used for cross-site scripting attacks. This vulnerability can lead to a full XSS on sites which have modified or disabled Discourse’s default Content Security Policy. Versions 2.8.14 and 3.0.0.beta16 contain a patch.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-22455?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2.8.14 |

Products: Discourse Discourse.

## How do I fix CVE-2023-22455?

Upgrade discourse to 2.8.14 or later.

## Is CVE-2023-22455 being exploited?

There is no known exploitation of CVE-2023-22455 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22455 and fix it if it is affected.

What it is: CVE-2023-22455 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 5 Jan 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-22455 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2.8.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22455/ (Markdown: https://insights.sbomify.com/CVE-2023-22455/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22455
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22455
- OSV: https://osv.dev/vulnerability/CVE-2023-22455

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22455/
Summaries are generated and may contain mistakes; the official description above is the record.
