CVE-2023-22457 org.xwiki.contrib:application-ckeditor-ui vulnerable to Remote Code Execution via Cross-Site Request Forgery

Critical 9.1 Published Updated

Attackers can trick privileged users into executing macros via CSRF, leading to remote code execution and privilege escalation in XWiki.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-22457?

CVE-2023-22457 is a critical vulnerability in xwiki-contrib application-ckeditor, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

CKEditor Integration UI adds support for editing wiki pages using CKEditor. Prior to versions 1.64.3,t he `CKEditor.HTMLConverter` document lacked a protection against Cross-Site Request Forgery (CSRF), allowing to execute macros with the rights of the current user. If a privileged user with programming rights was tricked into executing a GET request to this document with certain parameters (e.g., via an image with a corresponding URL embedded in a comment or via a redirect), this would allow arbitrary remote code execution and the attacker could gain rights, access private information or impact the availability of the wiki. The issue has been patched in the CKEditor Integration version 1.64.3. This has also been patched in the version of the CKEditor integration that is bundled starting with XWiki 14.6 RC1. There are no known workarounds for this other than upgrading the CKEditor integration to a fixed version.

Weakness: CWE-352

Which versions are affected by CVE-2023-22457?

2 open source packages ship an affected version, including org.xwiki.contrib:application-ckeditor-ui. It affects 1 product.

PackageAffectedFixed in
org.xwiki.contrib:application-ckeditor-ui MavenAll versions1.64.3
org.xwiki.contrib:application-ckeditor-ui MavenAll versions1.64.3

Products include Xwiki Ckeditor Integration.

How do I fix CVE-2023-22457?

Upgrade org.xwiki.contrib:application-ckeditor-ui to 1.64.3 or later.

Is CVE-2023-22457 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22457 exists.

Sources

Also known as GHSA-6mjp-2rm6-9g85, UBUNTU-CVE-2023-22457.

Is CVE-2023-22457 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free