{"answers":{"affected":"2 open source packages ship an affected version, including org.xwiki.contrib:application-ckeditor-ui. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22457 exists.","fix":"Upgrade org.xwiki.contrib:application-ckeditor-ui to 1.64.3 or later.","what":"CVE-2023-22457 is a critical vulnerability in xwiki-contrib application-ckeditor, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-22457 and fix it if it is affected.\n\nWhat it is: CVE-2023-22457 is a critical vulnerability in xwiki-contrib application-ckeditor, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22457 exists.\n\nAffected packages and fixed versions:\n- org.xwiki.contrib:application-ckeditor-ui (Maven): affected all versions; fixed in 1.64.3\n- org.xwiki.contrib:application-ckeditor-ui (Maven): affected all versions; fixed in 1.64.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-22457/ (Markdown: https://insights.sbomify.com/CVE-2023-22457/index.md)","id":"CVE-2023-22457","markdown":"https://insights.sbomify.com/CVE-2023-22457/index.md","name":"CVE-2023-22457","record":{"aliases":["GHSA-6mjp-2rm6-9g85","UBUNTU-CVE-2023-22457"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"XWiki CKEditor plugin","requires_auth":"low_privilege","summary":"Attackers can trick privileged users into executing macros via CSRF, leading to remote code execution and privilege escalation in XWiki.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ckeditor_integration","vendor":"xwiki"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"CKEditor Integration UI adds support for editing wiki pages using CKEditor. Prior to versions 1.64.3,t he `CKEditor.HTMLConverter` document lacked a protection against Cross-Site Request Forgery (CSRF), allowing to execute macros with the rights of the current user. If a privileged user with programming rights was tricked into executing a GET request to this document with certain parameters (e.g., via an image with a corresponding URL embedded in a comment or via a redirect), this would allow arbitrary remote code execution and the attacker could gain rights, access private information or impact the availability of the wiki. The issue has been patched in the CKEditor Integration version 1.64.3. This has also been patched in the version of the CKEditor integration that is bundled starting with XWiki 14.6 RC1. There are no known workarounds for this other than upgrading the CKEditor integration to a fixed version.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"org.xwiki.contrib:application-ckeditor-ui vulnerable to Remote Code Execution via Cross-Site Request Forgery","id":"CVE-2023-22457","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Integer overflow in multiple Redis commands can lead to denial-of-service","id":"CVE-2023-22458"},"packages":[{"ecosystem":"Maven","fixed":["1.64.3"],"introduced":["0"],"last_affected":[],"package":"org.xwiki.contrib:application-ckeditor-ui","purl":null,"source":"GHSA-6mjp-2rm6-9g85"},{"ecosystem":"Maven","fixed":["1.64.3"],"introduced":["0"],"last_affected":[],"package":"org.xwiki.contrib:application-ckeditor-ui","purl":"pkg:maven/org.xwiki.contrib/application-ckeditor-ui","source":"GHSA-6mjp-2rm6-9g85"}],"prev":{"headline":"ViewVC XSS vulnerability in revision view changed paths","id":"CVE-2023-22456"},"products":["application-ckeditor"],"published":"2023-01-04","related":[{"cvss_score":9.1,"headline":"Persistent Cross-site Scripting (XSS) through CKEditor Configuration pages in XWiki Platform","id":"CVE-2023-36477","kev_date_added":null,"published":"2023-06-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["xwiki-contrib"]},"summary":"Attackers can trick privileged users into executing macros via CSRF, leading to remote code execution and privilege escalation in XWiki.","url":"https://insights.sbomify.com/CVE-2023-22457/"}