# CVE-2023-22457: org.xwiki.contrib:application-ckeditor-ui vulnerable to Remote Code Execution via Cross-Site Request Forgery

> Attackers can trick privileged users into executing macros via CSRF, leading to remote code execution and privilege escalation in XWiki.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-6mjp-2rm6-9g85, UBUNTU-CVE-2023-22457

## What is CVE-2023-22457?

CVE-2023-22457 is a critical vulnerability in xwiki-contrib application-ckeditor, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

CKEditor Integration UI adds support for editing wiki pages using CKEditor. Prior to versions 1.64.3,t he `CKEditor.HTMLConverter` document lacked a protection against Cross-Site Request Forgery (CSRF), allowing to execute macros with the rights of the current user. If a privileged user with programming rights was tricked into executing a GET request to this document with certain parameters (e.g., via an image with a corresponding URL embedded in a comment or via a redirect), this would allow arbitrary remote code execution and the attacker could gain rights, access private information or impact the availability of the wiki. The issue has been patched in the CKEditor Integration version 1.64.3. This has also been patched in the version of the CKEditor integration that is bundled starting with XWiki 14.6 RC1. There are no known workarounds for this other than upgrading the CKEditor integration to a fixed version.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-22457?

2 open source packages ship an affected version, including org.xwiki.contrib:application-ckeditor-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.contrib:application-ckeditor-ui` | Maven | All versions | 1.64.3 |
| `org.xwiki.contrib:application-ckeditor-ui` | Maven | All versions | 1.64.3 |

Products: Xwiki Ckeditor Integration.

## How do I fix CVE-2023-22457?

Upgrade org.xwiki.contrib:application-ckeditor-ui to 1.64.3 or later.

## Is CVE-2023-22457 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22457 exists.

## Other vulnerabilities in xwiki-contrib application-ckeditor

- [CVE-2023-36477](https://insights.sbomify.com/CVE-2023-36477/): Persistent Cross-site Scripting (XSS) through CKEditor Configuration pages in XWiki Platform (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22457 and fix it if it is affected.

What it is: CVE-2023-22457 is a critical vulnerability in xwiki-contrib application-ckeditor, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22457 exists.

Affected packages and fixed versions:
- org.xwiki.contrib:application-ckeditor-ui (Maven): affected all versions; fixed in 1.64.3
- org.xwiki.contrib:application-ckeditor-ui (Maven): affected all versions; fixed in 1.64.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22457/ (Markdown: https://insights.sbomify.com/CVE-2023-22457/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22457
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22457
- OSV: https://osv.dev/vulnerability/CVE-2023-22457

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22457/
Summaries are generated and may contain mistakes; the official description above is the record.
