CVE-2023-22458 Integer overflow in multiple Redis commands can lead to denial-of-service

Medium 5.5 Published Updated

Authenticated users can crash Redis via integer overflow in HRANDFIELD or ZRANDMEMBER commands, causing denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2023-22458?

CVE-2023-22458 is a medium-severity vulnerability in redis, published on 20 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Redis is an in-memory database that persists on disk. Authenticated users can issue a `HRANDFIELD` or `ZRANDMEMBER` command with specially crafted arguments to trigger a denial-of-service by crashing Redis with an assertion failure. This problem affects Redis versions 6.2 or newer up to but not including 6.2.9 as well as versions 7.0 up to but not including 7.0.8. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-190

Which versions are affected by CVE-2023-22458?

3 open source packages ship an affected version, including redis, keydb and valkey. It affects 1 product.

PackageAffectedFixed in
redis BitnamiFrom 6.2.06.2.9, 7.0.8
keydb BitnamiFrom 6.2.06.2.9, 7.0.8
valkey BitnamiFrom 6.2.06.2.9, 7.0.8

Products include Redis Redis.

How do I fix CVE-2023-22458?

Upgrade redis to a fixed version for your release line: 6.2.9 or 7.0.8.

Is CVE-2023-22458 being exploited?

There is no known exploitation of CVE-2023-22458 in the wild and no public exploit code.

Sources

Also known as ALPINE-CVE-2023-22458, AZL-13053, BIT-keydb-2023-22458, BIT-redis-2023-22458, BIT-valkey-2023-22458, CLEANSTART-2026-VB06755 and 2 more.

Is CVE-2023-22458 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free