# CVE-2023-22460: go-ipld-prime json codec may panic if asked to encode bytes

> Attackers can cause a denial of service by triggering a panic in the go-ipld-prime JSON codec when encoding byte data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jan 2023
- **Updated:** 27 Aug 2026
- **Also known as:** GHSA-c653-6hhg-9x92, GO-2023-1269

## What is CVE-2023-22460?

CVE-2023-22460 is a high-severity denial of service vulnerability in go-ipld-prime, published on 4 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

go-ipld-prime is an implementation of the InterPlanetary Linked Data (IPLD) spec interfaces, a batteries-included codec implementations of IPLD for CBOR and JSON, and tooling for basic operations on IPLD objects. Encoding data which contains a Bytes kind Node will pass a Bytes token to the JSON encoder which will panic as it doesn't expect to receive Bytes tokens. Such an encode should be treated as an error, as plain JSON should not be able to encode Bytes. This only impacts uses of the `json` codec. `dag-json` is not impacted. Use of `json` as a decoder is not impacted. This issue is fixed in v0.19.0. As a workaround, one may prefer the `dag-json` codec, which has the ability to encode bytes.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-22460?

3 open source packages ship an affected version, including github.com/ipld/go-ipld-prime. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ipld/go-ipld-prime` | Go | All versions | 0.19.0 |
| `github.com/ipld/go-ipld-prime` | Go | All versions | 0.19.0 |
| `github.com/ipld/go-ipld-prime` | Go | All versions | 0.19.0 |

Products: Protocol Go-Ipld-Prime.

## How do I fix CVE-2023-22460?

Upgrade github.com/ipld/go-ipld-prime to 0.19.0 or later.

## Is CVE-2023-22460 being exploited?

There is no known exploitation of CVE-2023-22460 in the wild and no public exploit code.

## Other vulnerabilities in go-ipld-prime

- [CVE-2026-35480](https://insights.sbomify.com/CVE-2026-35480/): go-ipld-prime's DAG-CBOR decoder unbounded memory allocation from CBOR headers (medium 6.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22460 and fix it if it is affected.

What it is: CVE-2023-22460 is a high-severity denial of service vulnerability in go-ipld-prime, published on 4 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22460 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ipld/go-ipld-prime (Go): affected all versions; fixed in 0.19.0
- github.com/ipld/go-ipld-prime (Go): affected all versions; fixed in 0.19.0
- github.com/ipld/go-ipld-prime (Go): affected all versions; fixed in 0.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22460/ (Markdown: https://insights.sbomify.com/CVE-2023-22460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22460
- OSV: https://osv.dev/vulnerability/CVE-2023-22460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22460/
Summaries are generated and may contain mistakes; the official description above is the record.
