# CVE-2023-22461: sanitize-svg Filter Bypass Allows Cross-Site Scripting (XSS)

> Attackers can bypass SVG sanitization to inject malicious scripts, leading to cross-site scripting in applications using the library.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-h857-2g56-468g

## What is CVE-2023-22461?

CVE-2023-22461 is a high-severity cross-site scripting vulnerability in mattkrick sanitize-svg, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The `sanitize-svg` package, a small SVG sanitizer to prevent cross-site scripting attacks, uses a deny-list-pattern to sanitize SVGs to prevent XSS. In doing so, literal `<script>`-tags and on-event handlers were detected in versions prior to 0.4.0. As a result, downstream software that relies on `sanitize-svg` and expects resulting SVGs to be safe, may be vulnerable to cross-site scripting. This vulnerability was addressed in v0.4.0. There are no known workarounds

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-22461?

2 open source packages ship an affected version, including @mattkrick/sanitize-svg. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@mattkrick/sanitize-svg` | npm | All versions | 0.4.0 |
| `@mattkrick/sanitize-svg` | npm | All versions | 0.4.0 |

Products: Sanitize-Svg Project Sanitize-Svg.

## How do I fix CVE-2023-22461?

Upgrade @mattkrick/sanitize-svg to 0.4.0 or later.

## Is CVE-2023-22461 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22461 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22461 and fix it if it is affected.

What it is: CVE-2023-22461 is a high-severity cross-site scripting vulnerability in mattkrick sanitize-svg, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22461 exists.

Affected packages and fixed versions:
- @mattkrick/sanitize-svg (npm): affected all versions; fixed in 0.4.0
- @mattkrick/sanitize-svg (npm): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22461/ (Markdown: https://insights.sbomify.com/CVE-2023-22461/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22461
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22461
- OSV: https://osv.dev/vulnerability/CVE-2023-22461

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22461/
Summaries are generated and may contain mistakes; the official description above is the record.
