# CVE-2023-22463: KubePi's Hardcoded Jwtsigkeys allows malicious actor to login with a forged JWT token

> Attackers can forge JWT tokens using hardcoded keys to take over administrator accounts and compromise Kubernetes clusters.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-vjhf-8vqx-vqpq, GO-2023-1283

## What is CVE-2023-22463?

CVE-2023-22463 is a critical vulnerability in KubeOperator KubePi, published on 4 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

KubePi is a k8s panel. The jwt authentication function of KubePi through version 1.6.2 uses hard-coded Jwtsigkeys, resulting in the same Jwtsigkeys for all online projects. This means that an attacker can forge any jwt token to take over the administrator account of any online project. Furthermore, they may use the administrator to take over the k8s cluster of the target enterprise. `session.go`, the use of hard-coded JwtSigKey, allows an attacker to use this value to forge jwt tokens arbitrarily. The JwtSigKey is confidential and should not be hard-coded in the code. The vulnerability has been fixed in 1.6.3. In the patch, JWT key is specified in app.yml. If the user leaves it blank, a random key will be used. There are no workarounds aside from upgrading.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2023-22463?

3 open source packages ship an affected version, including github.com/KubeOperator/kubepi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/KubeOperator/kubepi` | Go | All versions | 1.6.3 |
| `github.com/KubeOperator/kubepi` | Go | All versions | 1.6.3 |
| `github.com/KubeOperator/kubepi` | Go | All versions | 1.6.3 |

Products: Fit2cloud Kubepi.

## How do I fix CVE-2023-22463?

Upgrade github.com/KubeOperator/kubepi to 1.6.3 or later.

## Is CVE-2023-22463 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22463 exists.

Public exploit code:

- KubePi JwtSigKey - Admin Authentication Bypass (nuclei): http/cves/2023/CVE-2023-22463.yaml

## Other vulnerabilities in KubeOperator KubePi

- [CVE-2023-37917](https://insights.sbomify.com/CVE-2023-37917/): Privilege Escalation in kubepi (critical 9.1)
- [CVE-2023-22479](https://insights.sbomify.com/CVE-2023-22479/): KubePi vulnerable to session fixation attack (high 7.5)
- [CVE-2023-22478](https://insights.sbomify.com/CVE-2023-22478/): KubePi is vulnerable to missing authorization (high 7.3)
- [CVE-2023-37916](https://insights.sbomify.com/CVE-2023-37916/): Leak password hash of any user (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22463 and fix it if it is affected.

What it is: CVE-2023-22463 is a critical vulnerability in KubeOperator KubePi, published on 4 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22463 exists.

Affected packages and fixed versions:
- github.com/KubeOperator/kubepi (Go): affected all versions; fixed in 1.6.3
- github.com/KubeOperator/kubepi (Go): affected all versions; fixed in 1.6.3
- github.com/KubeOperator/kubepi (Go): affected all versions; fixed in 1.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22463/ (Markdown: https://insights.sbomify.com/CVE-2023-22463/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22463
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22463
- OSV: https://osv.dev/vulnerability/CVE-2023-22463

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22463/
Summaries are generated and may contain mistakes; the official description above is the record.
