# CVE-2023-22464: ViewVC XSS vulnerability in revision view changed path "copyfrom" locations

> An attacker with commit privileges can inject malicious scripts via unsafe file names in ViewVC revision views, potentially executing code in victim browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-jvpj-293q-q53h, UBUNTU-CVE-2023-22464

## What is CVE-2023-22464?

CVE-2023-22464 is a medium-severity cross-site scripting vulnerability in viewvc, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

ViewVC is a browser interface for CVS and Subversion version control repositories. Versions prior to 1.2.3 and 1.1.30 are vulnerable to cross-site scripting. The impact of this vulnerability is mitigated by the need for an attacker to have commit privileges to a Subversion repository exposed by an otherwise trusted ViewVC instance. The attack vector involves files with unsafe names (names that, when embedded into an HTML stream, would cause the browser to run unwanted code), which themselves can be challenging to create. Users should update to at least version 1.2.3 (if they are using a 1.2.x version of ViewVC) or 1.1.30 (if they are using a 1.1.x version).

ViewVC 1.0.x is no longer supported, so users of that release lineage should implement one of the following workarounds. Users can edit their ViewVC EZT view templates to manually HTML-escape changed path "copyfrom paths" during rendering. Locate in your template set's `revision.ezt` file references to those changed paths, and wrap them with `[format "html"]` and `[end]`.  For most users, that means that references to `[changes.copy_path]` will become `[format "html"][changes.copy_path][end]`. (This workaround should be reverted after upgrading to a patched version of ViewVC, else "copyfrom path" names will be doubly escaped.)

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-22464?

It affects 1 product.


Products: Viewvc Viewvc.

## How do I fix CVE-2023-22464?

Upgrade to a fixed version.

## Is CVE-2023-22464 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22464 exists.

## Other vulnerabilities in viewvc

- [CVE-2025-54141](https://insights.sbomify.com/CVE-2025-54141/): ViewVC's standalone server exposes arbitrary server filesystem content (high 7.5)
- [CVE-2010-0005](https://insights.sbomify.com/CVE-2010-0005/): Auth bypass in n/a (high 7.5)
- [CVE-2006-5442](https://insights.sbomify.com/CVE-2006-5442/): Cross-site scripting in n/a (medium 6.8)
- [CVE-2023-22456](https://insights.sbomify.com/CVE-2023-22456/): ViewVC XSS vulnerability in revision view changed paths (medium 6.1)
- [CVE-2008-4325](https://insights.sbomify.com/CVE-2008-4325/): Cross-site scripting in n/a (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22464 and fix it if it is affected.

What it is: CVE-2023-22464 is a medium-severity cross-site scripting vulnerability in viewvc, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22464 exists.

Affected product: viewvc. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22464/ (Markdown: https://insights.sbomify.com/CVE-2023-22464/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22464
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22464
- OSV: https://osv.dev/vulnerability/CVE-2023-22464

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22464/
Summaries are generated and may contain mistakes; the official description above is the record.
