# CVE-2023-22467: luxon.js inefficient regular expression complexity vulnerability

> Attackers can cause denial of service in applications using Luxon by providing long inputs to DateTime.fromRFC2822, triggering quadratic regex complexity.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jan 2023
- **Updated:** 13 Feb 2025
- **Also known as:** CLSA-2026-1783731811, GHSA-3xq5-wjfh-ppjc, ROOT-APP-NPM-CVE-2023-22467

## What is CVE-2023-22467?

CVE-2023-22467 is a high-severity denial of service vulnerability in moment luxon, published on 4 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Luxon is a library for working with dates and times in JavaScript. On the 1.x branch prior to 1.38.1, the 2.x branch prior to 2.5.2, and the 3.x branch on 3.2.1, Luxon's `DateTime.fromRFC2822() has quadratic (N^2) complexity on some specific inputs. This causes a noticeable slowdown for inputs with lengths above 10k characters. Users providing untrusted data to this method are therefore vulnerable to (Re)DoS attacks. This issue also appears in Moment as CVE-2022-31129. Versions 1.38.1, 2.5.2, and 3.2.1 contain patches for this issue. As a workaround, limit the length of the input.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2023-22467?

6 open source packages ship an affected version, including luxon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `luxon` | npm | From 1.0.0 | 1.28.1 |
| `luxon` | npm | From 1.0.0 | 1.28.1 |
| `luxon` | npm | From 2.0.0 | 2.5.2 |
| `luxon` | npm | From 2.0.0 | 2.5.2 |
| `luxon` | npm | From 3.0.0 | 3.2.1 |
| `luxon` | npm | From 3.0.0 | 3.2.1 |

Products: Momentjs Luxon.

## How do I fix CVE-2023-22467?

Upgrade luxon to a fixed version for your release line: 1.28.1, 2.5.2 or 3.2.1.

## Is CVE-2023-22467 being exploited?

There is no known exploitation of CVE-2023-22467 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22467 and fix it if it is affected.

What it is: CVE-2023-22467 is a high-severity denial of service vulnerability in moment luxon, published on 4 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22467 in the wild and no public exploit code.

Affected packages and fixed versions:
- luxon (npm): affected from 1.0.0; fixed in 1.28.1
- luxon (npm): affected from 1.0.0; fixed in 1.28.1
- luxon (npm): affected from 2.0.0; fixed in 2.5.2
- luxon (npm): affected from 2.0.0; fixed in 2.5.2
- luxon (npm): affected from 3.0.0; fixed in 3.2.1
- luxon (npm): affected from 3.0.0; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22467/ (Markdown: https://insights.sbomify.com/CVE-2023-22467/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22467
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22467
- OSV: https://osv.dev/vulnerability/CVE-2023-22467

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22467/
Summaries are generated and may contain mistakes; the official description above is the record.
