CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes

High 8.8 Published Updated

Attackers can execute scripts via malicious URLs in posts on Discourse sites with disabled or permissive CSP, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-22468?

CVE-2023-22468 is a high-severity cross-site scripting vulnerability in Discourse Discourse, published on 26 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Discourse is an open source platform for community discussion. Versions prior to 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed), are vulnerable to cross-site Scripting. A maliciously crafted URL can be included in a post to carry out cross-site scripting attacks on sites with disabled or overly permissive CSP (Content Security Policy). Discourse's default CSP prevents this vulnerability. This vulnerability is patched in versions 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed). As a workaround, enable and/or restore your site's CSP to the default one provided with Discourse.

Weakness: CWE-79

Which versions are affected by CVE-2023-22468?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2.8.13

Products include Discourse Discourse.

How do I fix CVE-2023-22468?

Upgrade discourse to 2.8.13 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-22468 being exploited?

There is no known exploitation of CVE-2023-22468 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-22468, GHSA-8mr2-xf8r-wr8m.

Is CVE-2023-22468 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free