# CVE-2023-22468: Discourse vulnerable to Cross-site Scripting in local oneboxes

> Attackers can execute scripts via malicious URLs in posts on Discourse sites with disabled or permissive CSP, potentially leading to account takeover.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** BIT-discourse-2023-22468, GHSA-8mr2-xf8r-wr8m

## What is CVE-2023-22468?

CVE-2023-22468 is a high-severity cross-site scripting vulnerability in Discourse Discourse, published on 26 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Discourse is an open source platform for community discussion. Versions prior to 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed), are vulnerable to cross-site Scripting. A maliciously crafted URL can be included in a post to carry out cross-site  scripting attacks on sites with disabled or overly permissive CSP (Content Security Policy). Discourse's default CSP prevents this vulnerability. This vulnerability is patched in versions 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed). As a workaround, enable and/or restore your site's CSP to the default one provided with Discourse.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-22468?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2.8.13 |

Products: Discourse Discourse.

## How do I fix CVE-2023-22468?

Upgrade discourse to 2.8.13 or later.

## Is CVE-2023-22468 being exploited?

There is no known exploitation of CVE-2023-22468 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)
- [CVE-2025-48053](https://insights.sbomify.com/CVE-2025-48053/): Discourse vulnerable to DoS via large URL payload in PM to a bot (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22468 and fix it if it is affected.

What it is: CVE-2023-22468 is a high-severity cross-site scripting vulnerability in Discourse Discourse, published on 26 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-22468 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2.8.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22468/ (Markdown: https://insights.sbomify.com/CVE-2023-22468/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22468
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22468
- OSV: https://osv.dev/vulnerability/CVE-2023-22468

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22468/
Summaries are generated and may contain mistakes; the official description above is the record.
