# CVE-2023-22474: Parse Server is vulnerable to authentication bypass via spoofing

> Attackers can bypass masterKeyIps restrictions by spoofing the x-forwarded-for header when Parse Server is not configured to trust proxies.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2023
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-parse-2023-22474, GHSA-vm5r-c87r-pf6x

## What is CVE-2023-22474?

CVE-2023-22474 is a high-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 3 Feb 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Parse Server uses the request header `x-forwarded-for` to determine the client IP address. If Parse Server doesn't run behind a proxy server, then a client can set this header and Parse Server will trust the value of the header. The incorrect client IP address will be used by various features in Parse Server. This allows to circumvent the security mechanism of the Parse Server option `masterKeyIps` by setting an allowed IP address as the `x-forwarded-for` header value. This issue has been patched in version 5.4.1. The mechanism to determine the client IP address has been rewritten. The correct IP address determination now requires to set the Parse Server option `trustProxy`.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2023-22474?

3 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 5.4.1 |
| `parse-server` | npm | All versions | 5.4.1 |
| `parse` | Bitnami | All versions | 5.4.1 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2023-22474?

Upgrade parse-server to 5.4.1 or later.

## Is CVE-2023-22474 being exploited?

There is no known exploitation of CVE-2023-22474 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22474 and fix it if it is affected.

What it is: CVE-2023-22474 is a high-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 3 Feb 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22474 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 5.4.1
- parse-server (npm): affected all versions; fixed in 5.4.1
- parse (Bitnami): affected all versions; fixed in 5.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22474/ (Markdown: https://insights.sbomify.com/CVE-2023-22474/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22474
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22474
- OSV: https://osv.dev/vulnerability/CVE-2023-22474

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22474/
Summaries are generated and may contain mistakes; the official description above is the record.
