{"answers":{"affected":"2 open source packages ship an affected version, including github.com/KubeOperator/KubeOperator. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22480 exists.","fix":"No fix has been published for CVE-2023-22480 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-22480 is a high-severity missing authorization vulnerability in KubeOperator, published on 14 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-22480 and fix it if it is affected.\n\nWhat it is: CVE-2023-22480 is a high-severity missing authorization vulnerability in KubeOperator, published on 14 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22480 exists.\n\nAffected packages and fixed versions:\n- github.com/KubeOperator/KubeOperator (Go): affected all versions up to 3.16.3; no fix listed\n- github.com/KubeOperator/KubeOperator (Go): affected all versions up to 3.16.3; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-22480/ (Markdown: https://insights.sbomify.com/CVE-2023-22480/index.md)","id":"CVE-2023-22480","markdown":"https://insights.sbomify.com/CVE-2023-22480/index.md","name":"CVE-2023-22480","record":{"aliases":["GHSA-jxgp-jgh3-8jc8"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["data_read","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes management platform","requires_auth":"none","summary":"Attackers can access sensitive system APIs without authentication, potentially leading to cluster takeover in KubeOperator.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"kubeoperator","vendor":"fit2cloud"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-285","name":"Improper Authorization"}],"description":"KubeOperator is an open source Kubernetes distribution focused on helping enterprises plan, deploy and operate production-level K8s clusters. In KubeOperator versions 3.16.3 and below, API interfaces with unauthorized entities and can leak sensitive information. This vulnerability could be used to take over the cluster under certain conditions. This issue has been patched in version 3.16.4.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2023/CVE-2023-22480.yaml","stars":null,"title":"KubeOperator Foreground `kubeconfig` - File Download"}],"tier":"weaponised"},"has_fix":false,"headline":"KubeOperator is vulnerable to unauthorized access to system API","id":"CVE-2023-22480","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Sensitive information exposure in the logs of greader API in FreshRSS","id":"CVE-2023-22481"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":["3.16.3"],"package":"github.com/KubeOperator/KubeOperator","purl":null,"source":"GHSA-jxgp-jgh3-8jc8"},{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":["3.16.3"],"package":"github.com/KubeOperator/KubeOperator","purl":"pkg:golang/github.com/KubeOperator/KubeOperator","source":"GHSA-jxgp-jgh3-8jc8"}],"prev":{"headline":"KubePi vulnerable to session fixation attack","id":"CVE-2023-22479"},"products":["KubeOperator"],"published":"2023-01-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["KubeOperator"]},"summary":"Attackers can access sensitive system APIs without authentication, potentially leading to cluster takeover in KubeOperator.","url":"https://insights.sbomify.com/CVE-2023-22480/"}