# CVE-2023-22480: KubeOperator is vulnerable to unauthorized access to system API

> Attackers can access sensitive system APIs without authentication, potentially leading to cluster takeover in KubeOperator.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-jxgp-jgh3-8jc8

## What is CVE-2023-22480?

CVE-2023-22480 is a high-severity missing authorization vulnerability in KubeOperator, published on 14 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

KubeOperator is an open source Kubernetes distribution focused on helping enterprises plan, deploy and operate production-level K8s clusters. In KubeOperator versions 3.16.3 and below, API interfaces with unauthorized entities and can leak sensitive information. This vulnerability could be used to take over the cluster under certain conditions. This issue has been patched in version 3.16.4.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2023-22480?

2 open source packages ship an affected version, including github.com/KubeOperator/KubeOperator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/KubeOperator/KubeOperator` | Go | All versions to 3.16.3 | None |
| `github.com/KubeOperator/KubeOperator` | Go | All versions to 3.16.3 | None |

Products: Fit2cloud Kubeoperator.

## How do I fix CVE-2023-22480?

No fix has been published for CVE-2023-22480 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-22480 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22480 exists.

Public exploit code:

- KubeOperator Foreground `kubeconfig` - File Download (nuclei): http/cves/2023/CVE-2023-22480.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22480 and fix it if it is affected.

What it is: CVE-2023-22480 is a high-severity missing authorization vulnerability in KubeOperator, published on 14 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22480 exists.

Affected packages and fixed versions:
- github.com/KubeOperator/KubeOperator (Go): affected all versions up to 3.16.3; no fix listed
- github.com/KubeOperator/KubeOperator (Go): affected all versions up to 3.16.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22480/ (Markdown: https://insights.sbomify.com/CVE-2023-22480/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22480
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22480
- OSV: https://osv.dev/vulnerability/CVE-2023-22480

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22480/
Summaries are generated and may contain mistakes; the official description above is the record.
