CVE-2023-22499 Interactive permission prompt spoofing in Deno

High 7.5 Published Updated

Attackers can spoof interactive permission prompts in Deno via race conditions, bypassing security checks for users relying on interactive confirmations.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-22499?

CVE-2023-22499 is a high-severity vulnerability in denoland deno, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Deno is a runtime for JavaScript and TypeScript that uses V8 and is built in Rust. Multi-threaded programs were able to spoof interactive permission prompt by rewriting the prompt to suggest that program is waiting on user confirmation to unrelated action. A malicious program could clear the terminal screen after permission prompt was shown and write a generic message. This situation impacts users who use Web Worker API and relied on interactive permission prompt. The reproduction is very timing sensitive and can’t be reliably reproduced on every try. This problem can not be exploited on systems that do not attach an interactive prompt (for example headless servers). The problem has been fixed in Deno v1.29.3; it is recommended all users update to this version. Users are advised to upgrade. Users unable to upgrade may run with --no-prompt flag to disable interactive permission prompts.

Weakness: CWE-362

Which versions are affected by CVE-2023-22499?

2 open source packages ship an affected version, including deno. It affects 1 product.

PackageAffectedFixed in
deno crates.ioFrom 1.9.01.29.3
deno crates.ioFrom 1.9.01.29.3

Products include Deno Deno.

How do I fix CVE-2023-22499?

Upgrade deno to 1.29.3 or later.

Is CVE-2023-22499 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22499 exists.

Sources

Also known as GHSA-mc52-jpm2-cqh6, JLSEC-2026-100.

Is CVE-2023-22499 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free