{"answers":{"affected":"2 open source packages ship an affected version, including deno. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22499 exists.","fix":"Upgrade deno to 1.29.3 or later.","what":"CVE-2023-22499 is a high-severity vulnerability in denoland deno, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-22499 and fix it if it is affected.\n\nWhat it is: CVE-2023-22499 is a high-severity vulnerability in denoland deno, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22499 exists.\n\nAffected packages and fixed versions:\n- deno (crates.io): affected from 1.9.0; fixed in 1.29.3\n- deno (crates.io): affected from 1.9.0; fixed in 1.29.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-22499/ (Markdown: https://insights.sbomify.com/CVE-2023-22499/index.md)","id":"CVE-2023-22499","markdown":"https://insights.sbomify.com/CVE-2023-22499/index.md","name":"CVE-2023-22499","record":{"aliases":["GHSA-mc52-jpm2-cqh6","JLSEC-2026-100"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript runtime","requires_auth":"none","summary":"Attackers can spoof interactive permission prompts in Deno via race conditions, bypassing security checks for users relying on interactive confirmations.","user_interaction":"required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"deno","vendor":"deno"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"Deno is a runtime for JavaScript and TypeScript that uses V8 and is built in Rust. Multi-threaded programs were able to spoof interactive permission prompt by rewriting the prompt to suggest that program is waiting on user confirmation to unrelated action. A malicious program could clear the terminal screen after permission prompt was shown and write a generic message. This situation impacts users who use Web Worker API and relied on interactive permission prompt. The reproduction is very timing sensitive and can’t be reliably reproduced on every try. This problem can not be exploited on systems that do not attach an interactive prompt (for example headless servers). The problem has been fixed in Deno v1.29.3; it is recommended all users update to this version. Users are advised to upgrade. Users unable to upgrade may run with --no-prompt flag to disable interactive permission prompts.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Interactive permission prompt spoofing in Deno","id":"CVE-2023-22499","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"race_condition","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"glpi Unauthorized access to inventory files","id":"CVE-2023-22500"},"packages":[{"ecosystem":"crates.io","fixed":["1.29.3"],"introduced":["1.9.0"],"last_affected":[],"package":"deno","purl":null,"source":"GHSA-mc52-jpm2-cqh6"},{"ecosystem":"crates.io","fixed":["1.29.3"],"introduced":["1.9.0"],"last_affected":[],"package":"deno","purl":"pkg:cargo/deno","source":"GHSA-mc52-jpm2-cqh6"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2023-22498"},"products":["deno"],"published":"2023-01-17","related":[{"cvss_score":10,"headline":"Deno improperly handles resizable ArrayBuffer","id":"CVE-2023-28445","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":10,"headline":"Sandbox bypass leading to arbitrary code execution in Deno","id":"CVE-2022-24783","kev_date_added":null,"published":"2022-03-25"},{"cvss_score":9.8,"headline":"Static imports inside dynamically imported modules do not adhere to permission checks","id":"CVE-2021-32619","kev_date_added":null,"published":"2021-05-28"},{"cvss_score":9.2,"headline":"Deno node:crypto doesn't finalize cipher","id":"CVE-2026-22863","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":8.8,"headline":"Deno interactive permission prompt spoofing via improper ANSI stripping","id":"CVE-2024-27936","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":8.8,"headline":"Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization","id":"CVE-2023-28446","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":8.6,"headline":"Deno missing \"--allow-net\" permission check for built-in Node modules","id":"CVE-2023-33966","kev_date_added":null,"published":"2023-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["denoland"]},"summary":"Attackers can spoof interactive permission prompts in Deno via race conditions, bypassing security checks for users relying on interactive confirmations.","url":"https://insights.sbomify.com/CVE-2023-22499/"}