# CVE-2023-22499: Interactive permission prompt spoofing in Deno

> Attackers can spoof interactive permission prompts in Deno via race conditions, bypassing security checks for users relying on interactive confirmations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-mc52-jpm2-cqh6, JLSEC-2026-100

## What is CVE-2023-22499?

CVE-2023-22499 is a high-severity vulnerability in denoland deno, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Deno is a runtime for JavaScript and TypeScript that uses V8 and is built in Rust. Multi-threaded programs were able to spoof interactive permission prompt by rewriting the prompt to suggest that program is waiting on user confirmation to unrelated action. A malicious program could clear the terminal screen after permission prompt was shown and write a generic message. This situation impacts users who use Web Worker API and relied on interactive permission prompt. The reproduction is very timing sensitive and can’t be reliably reproduced on every try. This problem can not be exploited on systems that do not attach an interactive prompt (for example headless servers). The problem has been fixed in Deno v1.29.3; it is recommended all users update to this version. Users are advised to upgrade. Users unable to upgrade may run with --no-prompt flag to disable interactive permission prompts.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2023-22499?

2 open source packages ship an affected version, including deno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | From 1.9.0 | 1.29.3 |
| `deno` | crates.io | From 1.9.0 | 1.29.3 |

Products: Deno Deno.

## How do I fix CVE-2023-22499?

Upgrade deno to 1.29.3 or later.

## Is CVE-2023-22499 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22499 exists.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22499 and fix it if it is affected.

What it is: CVE-2023-22499 is a high-severity vulnerability in denoland deno, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22499 exists.

Affected packages and fixed versions:
- deno (crates.io): affected from 1.9.0; fixed in 1.29.3
- deno (crates.io): affected from 1.9.0; fixed in 1.29.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22499/ (Markdown: https://insights.sbomify.com/CVE-2023-22499/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22499
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22499
- OSV: https://osv.dev/vulnerability/CVE-2023-22499

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22499/
Summaries are generated and may contain mistakes; the official description above is the record.
