{"answers":{"affected":"2 open source packages ship an affected version, including yaml. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2251 exists.","fix":"Upgrade yaml to 2.2.2 or later.","what":"CVE-2023-2251 is a high-severity denial of service vulnerability in eemeli/yaml, published on 24 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-2251 and fix it if it is affected.\n\nWhat it is: CVE-2023-2251 is a high-severity denial of service vulnerability in eemeli/yaml, published on 24 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2251 exists.\n\nAffected packages and fixed versions:\n- yaml (npm): affected from 2.0.0-5; fixed in 2.2.2\n- yaml (npm): affected from 2.0.0-5; fixed in 2.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-2251/ (Markdown: https://insights.sbomify.com/CVE-2023-2251/index.md)","id":"CVE-2023-2251","markdown":"https://insights.sbomify.com/CVE-2023-2251/index.md","name":"CVE-2023-2251","record":{"aliases":["DEBIAN-CVE-2023-2251","GHSA-f9xv-q969-pqx4","ROOT-APP-NPM-CVE-2023-2251","UBUNTU-CVE-2023-2251","openSUSE-SU-2024:12888-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript YAML parser","requires_auth":"none","summary":"An attacker can cause a denial of service by triggering an uncaught exception in the YAML parser library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"yaml","vendor":"yaml_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"Uncaught Exception in GitHub repository eemeli/yaml prior to 2.0.0-5.","ecosystems":["npm","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Uncaught Exception in eemeli/yaml","id":"CVE-2023-2251","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Directorist \u003c 7.5.4 - Admin+ LFI","id":"CVE-2023-2252"},"packages":[{"ecosystem":"npm","fixed":["2.2.2"],"introduced":["2.0.0-5"],"last_affected":[],"package":"yaml","purl":null,"source":"GHSA-f9xv-q969-pqx4"},{"ecosystem":"npm","fixed":["2.2.2"],"introduced":["2.0.0-5"],"last_affected":[],"package":"yaml","purl":"pkg:npm/yaml","source":"GHSA-f9xv-q969-pqx4"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.11.30-2.1"],"introduced":["0"],"last_affected":[],"package":"element-web","purl":"pkg:rpm/opensuse/element-web\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12888-1"}],"prev":{"headline":"Privilege escalation in MCE","id":"CVE-2023-2250"},"products":["eemeli/yaml"],"published":"2023-04-24","related":[{"cvss_score":7.5,"headline":"Excessive resource consumption in gopkg.in/yaml.v2","id":"CVE-2022-3064","kev_date_added":null,"published":"2022-12-27"},{"cvss_score":5.5,"headline":"Denial of service in gopkg.in/yaml.v2","id":"CVE-2021-4235","kev_date_added":null,"published":"2022-12-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-04","vendors":["eemeli"]},"summary":"An attacker can cause a denial of service by triggering an uncaught exception in the YAML parser library.","url":"https://insights.sbomify.com/CVE-2023-2251/"}