# CVE-2023-2251: Uncaught Exception in eemeli/yaml

> An attacker can cause a denial of service by triggering an uncaught exception in the YAML parser library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2023
- **Updated:** 4 Feb 2025
- **Also known as:** DEBIAN-CVE-2023-2251, GHSA-f9xv-q969-pqx4, ROOT-APP-NPM-CVE-2023-2251, UBUNTU-CVE-2023-2251, openSUSE-SU-2024:12888-1

## What is CVE-2023-2251?

CVE-2023-2251 is a high-severity denial of service vulnerability in eemeli/yaml, published on 24 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Uncaught Exception in GitHub repository eemeli/yaml prior to 2.0.0-5.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2023-2251?

2 open source packages ship an affected version, including yaml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yaml` | npm | From 2.0.0-5 | 2.2.2 |
| `yaml` | npm | From 2.0.0-5 | 2.2.2 |
| `element-web` | openSUSE:Tumbleweed | All versions | 1.11.30-2.1 |

Products: Yaml Project Yaml.

## How do I fix CVE-2023-2251?

Upgrade yaml to 2.2.2 or later.

## Is CVE-2023-2251 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2251 exists.

## Other vulnerabilities in eemeli/yaml

- [CVE-2022-3064](https://insights.sbomify.com/CVE-2022-3064/): Excessive resource consumption in gopkg.in/yaml.v2 (high 7.5)
- [CVE-2021-4235](https://insights.sbomify.com/CVE-2021-4235/): Denial of service in gopkg.in/yaml.v2 (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2251 and fix it if it is affected.

What it is: CVE-2023-2251 is a high-severity denial of service vulnerability in eemeli/yaml, published on 24 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2251 exists.

Affected packages and fixed versions:
- yaml (npm): affected from 2.0.0-5; fixed in 2.2.2
- yaml (npm): affected from 2.0.0-5; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2251/ (Markdown: https://insights.sbomify.com/CVE-2023-2251/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2251
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2251
- OSV: https://osv.dev/vulnerability/CVE-2023-2251

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2251/
Summaries are generated and may contain mistakes; the official description above is the record.
