CVE-2023-22512 Denial of service in Confluence Data Center

High 7.5 Published Updated

Unauthenticated attackers can disrupt Confluence services, causing denial of service for intended users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-22512?

CVE-2023-22512 is a high-severity denial of service vulnerability in Atlassian Confluence Data Center, published on 17 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

This High severity DoS (Denial of Service) vulnerability was introduced in version 5.6.0 of Confluence Data Center and Server. With a CVSS Score of 7.5, this vulnerability allows an unauthenticated attacker to cause a resource to be unavailable for its intended users by temporarily or indefinitely disrupting services of a vulnerable host (Confluence instance) connected to a network, which has no impact to confidentiality, no impact to integrity, high impact to availability, and requires no user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Confluence Data Center and Server 7.19: Upgrade to a release greater than or equal to 7.19.14 Confluence Data Center and Server 8.5: Upgrade to a release greater than or equal to 8.5.1 Confluence Data Center and Server 8.6 or above: No need to upgrade, you're already on a patched version See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html ). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives ]). This vulnerability was reported via our Bug Bounty program.

Weakness: CWE-400

Which versions are affected by CVE-2023-22512?

It affects 2 products.

Products include Atlassian Confluence Data Center, Atlassian Confluence Server.

How do I fix CVE-2023-22512?

No fix has been published for CVE-2023-22512 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-22512 being exploited?

There is no known exploitation of CVE-2023-22512 in the wild and no public exploit code.

Sources

Also known as GHSA-h33j-9q95-27j4.

Is CVE-2023-22512 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free