{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-22516 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-22516 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-22516 is a high-severity code injection vulnerability in Atlassian Bamboo Data Center, published on 21 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-22516 and fix it if it is affected.\n\nWhat it is: CVE-2023-22516 is a high-severity code injection vulnerability in Atlassian Bamboo Data Center, published on 21 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-22516 in the wild and no public exploit code.\n\nAffected product: Atlassian Bamboo Data Center. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-22516/ (Markdown: https://insights.sbomify.com/CVE-2023-22516/index.md)","id":"CVE-2023-22516","markdown":"https://insights.sbomify.com/CVE-2023-22516/index.md","name":"CVE-2023-22516","record":{"aliases":["GHSA-xqv7-xc39-ph8v"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"CI/CD server","requires_auth":"low_privilege","summary":"Authenticated attackers can execute arbitrary code on Atlassian Bamboo servers, compromising confidentiality, integrity, and availability.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"atlassian","cpe":[{"product":"bamboo","vendor":"atlassian"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"This High severity RCE (Remote Code Execution) vulnerability was introduced in versions 8.1.0, 8.2.0, 9.0.0, 9.1.0, 9.2.0, and 9.3.0 of Bamboo Data Center and Server.\r\n\r\nThis RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8.5, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires no user interaction.\r\n\r\nAtlassian recommends that Bamboo Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions:\r\n Bamboo Data Center and Server 9.2: Upgrade to a release greater than or equal to 9.2.7.\r\n  JDK 1.8u121+ should be used in case Java 8 used to run Bamboo Data Center and Server. See Bamboo 9.2 Upgrade notes (https://confluence.atlassian.com/bambooreleases/bamboo-9-2-upgrade-notes-1207179212.html)\r\n\r\n Bamboo Data Center and Server 9.3: Upgrade to a release greater than or equal to 9.3.4\r\n\r\nSee the release notes ([https://confluence.atlassian.com/bambooreleases/bamboo-release-notes-1189793869.html]). You can download the latest version of Bamboo Data Center and Server from the download center ([https://www.atlassian.com/software/bamboo/download-archives]).\r\n\r\nThis vulnerability was discovered by a private user and reported via our Bug Bounty program","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Code injection in Bamboo Data Center","id":"CVE-2023-22516","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":0,"n_references":2,"next":{"headline":"Atlassian Confluence Data Center and Server Improper Authorization","id":"CVE-2023-22518"},"packages":[],"prev":{"headline":"Atlassian Confluence Data Center and Server Broken Access Control","id":"CVE-2023-22515"},"products":["Bamboo Data Center","Bamboo Server"],"published":"2023-11-21","related":[{"cvss_score":9.3,"headline":"Atlassian Multiple Products Files or Directories Accessible to External Parties","id":"CVE-2026-21589","kev_date_added":"2026-10-15","published":"2026-10-05"},{"cvss_score":9.8,"headline":"Auth bypass in Bamboo Data Center","id":"CVE-2022-26136","kev_date_added":null,"published":"2022-07-20"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2016-5229","kev_date_added":null,"published":"2016-08-02"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2014-9757","kev_date_added":null,"published":"2016-02-08"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2015-8360","kev_date_added":null,"published":"2016-02-08"},{"cvss_score":9.6,"headline":"Code injection in Bamboo","id":"CVE-2017-14589","kev_date_added":null,"published":"2017-12-13"},{"cvss_score":9.4,"headline":"Command injection in Bamboo Data Center","id":"CVE-2026-21571","kev_date_added":null,"published":"2026-04-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-21","vendors":["Atlassian"]},"summary":"Authenticated attackers can execute arbitrary code on Atlassian Bamboo servers, compromising confidentiality, integrity, and availability.","url":"https://insights.sbomify.com/CVE-2023-22516/"}