# CVE-2023-22516: Code injection in Bamboo Data Center

> Authenticated attackers can execute arbitrary code on Atlassian Bamboo servers, compromising confidentiality, integrity, and availability.

- **Severity:** High 8.5 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Nov 2023
- **Updated:** 21 Oct 2024
- **Also known as:** GHSA-xqv7-xc39-ph8v

## What is CVE-2023-22516?

CVE-2023-22516 is a high-severity code injection vulnerability in Atlassian Bamboo Data Center, published on 21 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

This High severity RCE (Remote Code Execution) vulnerability was introduced in versions 8.1.0, 8.2.0, 9.0.0, 9.1.0, 9.2.0, and 9.3.0 of Bamboo Data Center and Server.

This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8.5, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires no user interaction.

Atlassian recommends that Bamboo Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions:
 Bamboo Data Center and Server 9.2: Upgrade to a release greater than or equal to 9.2.7.
  JDK 1.8u121+ should be used in case Java 8 used to run Bamboo Data Center and Server. See Bamboo 9.2 Upgrade notes (https://confluence.atlassian.com/bambooreleases/bamboo-9-2-upgrade-notes-1207179212.html)

 Bamboo Data Center and Server 9.3: Upgrade to a release greater than or equal to 9.3.4

See the release notes ([https://confluence.atlassian.com/bambooreleases/bamboo-release-notes-1189793869.html]). You can download the latest version of Bamboo Data Center and Server from the download center ([https://www.atlassian.com/software/bamboo/download-archives]).

This vulnerability was discovered by a private user and reported via our Bug Bounty program

## Which versions are affected by CVE-2023-22516?

It affects 1 product.


Products: Atlassian Bamboo.

## How do I fix CVE-2023-22516?

No fix has been published for CVE-2023-22516 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-22516 being exploited?

There is no known exploitation of CVE-2023-22516 in the wild and no public exploit code.

## Other vulnerabilities in Atlassian Bamboo Data Center

- [CVE-2026-21589](https://insights.sbomify.com/CVE-2026-21589/): Atlassian Multiple Products Files or Directories Accessible to External Parties (critical 9.3, exploited in the wild)
- [CVE-2022-26136](https://insights.sbomify.com/CVE-2022-26136/): Auth bypass in Bamboo Data Center (critical 9.8)
- [CVE-2016-5229](https://insights.sbomify.com/CVE-2016-5229/): Deserialization in n/a (critical 9.8)
- [CVE-2014-9757](https://insights.sbomify.com/CVE-2014-9757/): Deserialization in n/a (critical 9.8)
- [CVE-2015-8360](https://insights.sbomify.com/CVE-2015-8360/): Deserialization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22516 and fix it if it is affected.

What it is: CVE-2023-22516 is a high-severity code injection vulnerability in Atlassian Bamboo Data Center, published on 21 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22516 in the wild and no public exploit code.

Affected product: Atlassian Bamboo Data Center. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22516/ (Markdown: https://insights.sbomify.com/CVE-2023-22516/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22516
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22516
- OSV: https://osv.dev/vulnerability/CVE-2023-22516

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22516/
Summaries are generated and may contain mistakes; the official description above is the record.
