{"answers":{"affected":"4 open source packages ship an affected version, including @strapi/plugin-email and @strapi/plugin-users-permissions. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22621 exists.","fix":"Upgrade @strapi/plugin-email to 4.5.6 or later.","what":"CVE-2023-22621 is a critical code injection vulnerability in n/a, published on 19 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-22621 and fix it if it is affected.\n\nWhat it is: CVE-2023-22621 is a critical code injection vulnerability in n/a, published on 19 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22621 exists.\n\nAffected packages and fixed versions:\n- @strapi/plugin-email (npm): affected all versions; fixed in 4.5.6\n- @strapi/plugin-email (npm): affected all versions; fixed in 4.5.6\n- @strapi/plugin-users-permissions (npm): affected all versions; fixed in 4.5.6\n- @strapi/plugin-users-permissions (npm): affected all versions; fixed in 4.5.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-22621/ (Markdown: https://insights.sbomify.com/CVE-2023-22621/index.md)","id":"CVE-2023-22621","markdown":"https://insights.sbomify.com/CVE-2023-22621/index.md","name":"CVE-2023-22621","record":{"aliases":["GHSA-2h87-4q2w-v4hf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Strapi CMS","requires_auth":"none","summary":"Authenticated attackers can execute arbitrary code on the server via Server-Side Template Injection in email templates.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"strapi","vendor":"strapi"}],"cvss":{"score":10,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Strapi through 4.5.5 allows authenticated Server-Side Template Injection (SSTI) that can be exploited to execute arbitrary code on the server. A remote attacker with access to the Strapi admin panel can inject a crafted payload that executes code on the server into an email template that bypasses the validation checks that should prevent code execution.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2023-04-25","github_poc":1,"max_poc_stars":23,"metasploit":0,"nuclei":1,"refs":[{"date":"2023-04-25T15:50:05Z","kind":"github_poc","ref":"https://github.com/sofianeelhor/CVE-2023-22621-POC","stars":23,"title":"CVE-2023-22621: SSTI to RCE by Exploiting Email Templates affecting Strapi Versions \u003c=4.5.5"},{"date":null,"kind":"nuclei","ref":"http/cves/2023/CVE-2023-22621.yaml","stars":null,"title":"Strapi Versions \u003c=4.5.5 - SSTI to Remote Code Execution"}],"tier":"weaponised"},"has_fix":true,"headline":"Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin","id":"CVE-2023-22621","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":4,"n_references":3,"next":{"headline":"Misconfiguration in n/a","id":"CVE-2023-22622"},"packages":[{"ecosystem":"npm","fixed":["4.5.6"],"introduced":["0"],"last_affected":[],"package":"@strapi/plugin-email","purl":null,"source":"GHSA-2h87-4q2w-v4hf"},{"ecosystem":"npm","fixed":["4.5.6"],"introduced":["0"],"last_affected":[],"package":"@strapi/plugin-email","purl":"pkg:npm/%40strapi/plugin-email","source":"GHSA-2h87-4q2w-v4hf"},{"ecosystem":"npm","fixed":["4.5.6"],"introduced":["0"],"last_affected":[],"package":"@strapi/plugin-users-permissions","purl":null,"source":"GHSA-2h87-4q2w-v4hf"},{"ecosystem":"npm","fixed":["4.5.6"],"introduced":["0"],"last_affected":[],"package":"@strapi/plugin-users-permissions","purl":"pkg:npm/%40strapi/plugin-users-permissions","source":"GHSA-2h87-4q2w-v4hf"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2023-22620"},"products":["n/a"],"published":"2023-04-19","related":[{"cvss_score":7.2,"headline":"Strapi Cleartext Storage of Sensitive Information","id":"CVE-2023-22894","kev_date_added":"2026-10-08","published":"2023-04-19"},{"cvss_score":9.8,"headline":"Unrestricted Upload of File with Dangerous Type in Strapi","id":"CVE-2022-27263","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":9.8,"headline":"Authorization bypass in Strapi","id":"CVE-2020-27664","kev_date_added":null,"published":"2020-10-22"},{"cvss_score":9.8,"headline":"Strapi allows unauthenticated attacker to reset admin password without valid reset token","id":"CVE-2019-18818","kev_date_added":null,"published":"2019-11-07"},{"cvss_score":9.3,"headline":"Strapi Vulnerable to SQL Injection in Content Type Builder","id":"CVE-2026-22599","kev_date_added":null,"published":"2026-05-14"},{"cvss_score":9.2,"headline":"Strapi may leak sensitive data via relational filtering due to lack of query sanitization","id":"CVE-2026-27886","kev_date_added":null,"published":"2026-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-07","vendors":["n/a"]},"summary":"Authenticated attackers can execute arbitrary code on the server via Server-Side Template Injection in email templates.","url":"https://insights.sbomify.com/CVE-2023-22621/"}