# CVE-2023-22621: Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin

> Authenticated attackers can execute arbitrary code on the server via Server-Side Template Injection in email templates.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Apr 2023
- **Updated:** 7 Nov 2025
- **Also known as:** GHSA-2h87-4q2w-v4hf

## What is CVE-2023-22621?

CVE-2023-22621 is a critical code injection vulnerability in n/a, published on 19 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Strapi through 4.5.5 allows authenticated Server-Side Template Injection (SSTI) that can be exploited to execute arbitrary code on the server. A remote attacker with access to the Strapi admin panel can inject a crafted payload that executes code on the server into an email template that bypasses the validation checks that should prevent code execution.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-22621?

4 open source packages ship an affected version, including @strapi/plugin-email and @strapi/plugin-users-permissions. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/plugin-email` | npm | All versions | 4.5.6 |
| `@strapi/plugin-email` | npm | All versions | 4.5.6 |
| `@strapi/plugin-users-permissions` | npm | All versions | 4.5.6 |
| `@strapi/plugin-users-permissions` | npm | All versions | 4.5.6 |

Products: Strapi Strapi.

## How do I fix CVE-2023-22621?

Upgrade @strapi/plugin-email to 4.5.6 or later.

## Is CVE-2023-22621 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22621 exists.

Public exploit code:

- CVE-2023-22621: SSTI to RCE by Exploiting Email Templates affecting Strapi Versions <=4.5.5 (github_poc): https://github.com/sofianeelhor/CVE-2023-22621-POC
- Strapi Versions <=4.5.5 - SSTI to Remote Code Execution (nuclei): http/cves/2023/CVE-2023-22621.yaml

## Other vulnerabilities in n/a

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)
- [CVE-2026-22599](https://insights.sbomify.com/CVE-2026-22599/): Strapi Vulnerable to SQL Injection in Content Type Builder (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22621 and fix it if it is affected.

What it is: CVE-2023-22621 is a critical code injection vulnerability in n/a, published on 19 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22621 exists.

Affected packages and fixed versions:
- @strapi/plugin-email (npm): affected all versions; fixed in 4.5.6
- @strapi/plugin-email (npm): affected all versions; fixed in 4.5.6
- @strapi/plugin-users-permissions (npm): affected all versions; fixed in 4.5.6
- @strapi/plugin-users-permissions (npm): affected all versions; fixed in 4.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22621/ (Markdown: https://insights.sbomify.com/CVE-2023-22621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22621
- OSV: https://osv.dev/vulnerability/CVE-2023-22621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22621/
Summaries are generated and may contain mistakes; the official description above is the record.
