{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-22622 in the wild and no public exploit code.","fix":"Upgrade wordpress to 6.1.2 or later.","what":"CVE-2023-22622 is a medium-severity vulnerability in Wordpress Wordpress, published on 5 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-22622 and fix it if it is affected.\n\nWhat it is: CVE-2023-22622 is a medium-severity vulnerability in Wordpress Wordpress, published on 5 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-22622 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 6.1.2\n- wordpress-multisite (Bitnami): affected all versions; fixed in 6.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-22622/ (Markdown: https://insights.sbomify.com/CVE-2023-22622/index.md)","id":"CVE-2023-22622","markdown":"https://insights.sbomify.com/CVE-2023-22622/index.md","name":"CVE-2023-22622","record":{"aliases":["BIT-wordpress-2023-22622","BIT-wordpress-multisite-2023-22622","GHSA-pmh6-cq54-943m","UBUNTU-CVE-2023-22622"],"analysis":{"component_type":"web_application","fix_type":"configuration_change","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"WordPress CMS","requires_auth":"none","summary":"WordPress sites with low traffic may miss critical security updates due to reliance on visitor-triggered cron jobs, requiring manual configuration to ensure timely patching.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"WordPress through 6.1.1 depends on unpredictable client visits to cause wp-cron.php execution and the resulting security updates, and the source code describes \"the scenario where a site may not receive enough visits to execute scheduled tasks in a timely manner,\" but neither the installation guide nor the security guide mentions this default behavior, or alerts the user about security risks on installations with very few visits.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2024-03-20","github_poc":1,"max_poc_stars":4,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-03-20T13:48:48Z","kind":"github_poc","ref":"https://github.com/michael-david-fry/CVE-2023-22622","stars":4,"title":"Python Script that will DoS a WP server that is utilizing WP-CRON"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Misconfiguration in n/a","id":"CVE-2023-22622","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"wordpress:wordpress","products":["wordpress:wordpress"],"type":"misconfiguration","year":"2023"},"n_packages":2,"n_references":7,"next":{"headline":"XML external entity in n/a","id":"CVE-2023-22624"},"packages":[{"ecosystem":"Bitnami","fixed":["6.1.2"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2023-22622"},{"ecosystem":"Bitnami","fixed":["6.1.2"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2023-22622"}],"prev":{"headline":"Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin","id":"CVE-2023-22621"},"products":["n/a"],"published":"2023-01-05","related":[{"cvss_score":9.8,"headline":"WordPress Core Interpretation Conflict","id":"CVE-2026-63030","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":8.1,"headline":"WordPress Core Remote File Inclusion","id":"CVE-2026-87902","kev_date_added":"2026-09-25","published":"2026-09-22"},{"cvss_score":5.9,"headline":"WordPress Core SQL Injection","id":"CVE-2026-60137","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2012-2399","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2012-2400","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3122","kev_date_added":null,"published":"2011-08-10"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3125","kev_date_added":null,"published":"2011-08-10"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-07","vendors":["n/a"]},"summary":"WordPress sites with low traffic may miss critical security updates due to reliance on visitor-triggered cron jobs, requiring manual configuration to ensure timely patching.","url":"https://insights.sbomify.com/CVE-2023-22622/"}