# CVE-2023-22622: Misconfiguration in n/a

> WordPress sites with low traffic may miss critical security updates due to reliance on visitor-triggered cron jobs, requiring manual configuration to ensure timely patching.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2023
- **Updated:** 7 Apr 2025
- **Also known as:** BIT-wordpress-2023-22622, BIT-wordpress-multisite-2023-22622, GHSA-pmh6-cq54-943m, UBUNTU-CVE-2023-22622

## What is CVE-2023-22622?

CVE-2023-22622 is a medium-severity vulnerability in Wordpress Wordpress, published on 5 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

WordPress through 6.1.1 depends on unpredictable client visits to cause wp-cron.php execution and the resulting security updates, and the source code describes "the scenario where a site may not receive enough visits to execute scheduled tasks in a timely manner," but neither the installation guide nor the security guide mentions this default behavior, or alerts the user about security risks on installations with very few visits.

## Which versions are affected by CVE-2023-22622?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 6.1.2 |
| `wordpress-multisite` | Bitnami | All versions | 6.1.2 |

Products: Wordpress Wordpress.

## How do I fix CVE-2023-22622?

Upgrade wordpress to 6.1.2 or later.

## Is CVE-2023-22622 being exploited?

There is no known exploitation of CVE-2023-22622 in the wild and no public exploit code.

Public exploit code:

- Python Script that will DoS a WP server that is utilizing WP-CRON (github_poc): https://github.com/michael-david-fry/CVE-2023-22622

## Other vulnerabilities in Wordpress Wordpress

- [CVE-2026-63030](https://insights.sbomify.com/CVE-2026-63030/): WordPress Core Interpretation Conflict (critical 9.8, exploited in the wild)
- [CVE-2026-87902](https://insights.sbomify.com/CVE-2026-87902/): WordPress Core Remote File Inclusion (high 8.1, exploited in the wild)
- [CVE-2026-60137](https://insights.sbomify.com/CVE-2026-60137/): WordPress Core SQL Injection (medium 5.9, exploited in the wild)
- [CVE-2012-2399](https://insights.sbomify.com/CVE-2012-2399/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2012-2400](https://insights.sbomify.com/CVE-2012-2400/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22622 and fix it if it is affected.

What it is: CVE-2023-22622 is a medium-severity vulnerability in Wordpress Wordpress, published on 5 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22622 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 6.1.2
- wordpress-multisite (Bitnami): affected all versions; fixed in 6.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22622/ (Markdown: https://insights.sbomify.com/CVE-2023-22622/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22622
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22622
- OSV: https://osv.dev/vulnerability/CVE-2023-22622

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22622/
Summaries are generated and may contain mistakes; the official description above is the record.
