# CVE-2023-22626: PgHero Allows Information Disclosure Through EXPLAIN Feature


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Jan 2023
- **Updated:** 7 Apr 2025
- **Also known as:** GHSA-vf99-xw26-86g5

## What is CVE-2023-22626?

CVE-2023-22626 is a high-severity vulnerability in n/a, published on 5 Jan 2023. 

### Official description

PgHero before 3.1.0 allows Information Disclosure via EXPLAIN because query results may be present in an error message. (Depending on database user privileges, this may only be information from the database, or may be information from file contents on the database server.)

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2023-22626?

2 open source packages ship an affected version, including pghero. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pghero` | RubyGems | All versions | 3.1.0 |
| `pghero` | RubyGems | All versions | 3.1.0 |

Products: Pghero Project Pghero.

## How do I fix CVE-2023-22626?

Upgrade pghero to 3.1.0 or later.

## Is CVE-2023-22626 being exploited?

There is no known exploitation of CVE-2023-22626 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-16253](https://insights.sbomify.com/CVE-2020-16253/): PgHero gem allows CSRF (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22626 and fix it if it is affected.

What it is: CVE-2023-22626 is a high-severity vulnerability in n/a, published on 5 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2023-22626 in the wild and no public exploit code.

Affected packages and fixed versions:
- pghero (RubyGems): affected all versions; fixed in 3.1.0
- pghero (RubyGems): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22626/ (Markdown: https://insights.sbomify.com/CVE-2023-22626/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22626
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22626
- OSV: https://osv.dev/vulnerability/CVE-2023-22626

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22626/
Summaries are generated and may contain mistakes; the official description above is the record.
