# CVE-2023-22648: Rancher's Azure AD permission changes are not reflected on active sessions

> Users retain elevated Rancher permissions after Azure AD group changes, allowing unauthorized access to resources.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jun 2023
- **Updated:** 9 Oct 2024
- **Also known as:** GHSA-vf6j-6739-78m8

## What is CVE-2023-22648?

CVE-2023-22648 is a high-severity vulnerability in SUSE Rancher, published on 1 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A Improper Privilege Management vulnerability in SUSE Rancher causes permission changes in Azure AD not to be reflected to users 
while they are logged in the Rancher UI. This would cause the users to 
retain their previous permissions in Rancher, even if they change groups
 on Azure AD, for example, to a lower privileged group, or are removed 
from a group, thus retaining their access to Rancher instead of losing 
it.
This issue affects Rancher: from >= 2.6.7 before < 2.6.13, from >= 2.7.0 before < 2.7.4.

Weakness: CWE-271 (Privilege Dropping / Lowering Errors)

## Which versions are affected by CVE-2023-22648?

4 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | From 2.6.7 | 2.6.13 |
| `github.com/rancher/rancher` | Go | From 2.6.7 | 2.6.13 |
| `github.com/rancher/rancher` | Go | From 2.7.0 | 2.7.4 |
| `github.com/rancher/rancher` | Go | From 2.7.0 | 2.7.4 |

Products: Suse Rancher.

## How do I fix CVE-2023-22648?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.6.13 or 2.7.4.

## Is CVE-2023-22648 being exploited?

There is no known exploitation of CVE-2023-22648 in the wild and no public exploit code.

## Other vulnerabilities in SUSE Rancher

- [CVE-2023-22647](https://insights.sbomify.com/CVE-2023-22647/): Rancher vulnerable to Privilege Escalation via manipulation of Secrets (critical 9.9)
- [CVE-2023-22651](https://insights.sbomify.com/CVE-2023-22651/): Rancher Webhook is misconfigured during upgrade process (critical 9.9)
- [CVE-2022-43757](https://insights.sbomify.com/CVE-2022-43757/): Rancher: Exposure of sensitive fields (critical 9.9)
- [CVE-2021-36782](https://insights.sbomify.com/CVE-2021-36782/): Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object (critical 9.9)
- [CVE-2021-36783](https://insights.sbomify.com/CVE-2021-36783/): Rancher: Failure to properly sanitize credentials in cluster template answers (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22648 and fix it if it is affected.

What it is: CVE-2023-22648 is a high-severity vulnerability in SUSE Rancher, published on 1 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-22648 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected from 2.6.7; fixed in 2.6.13
- github.com/rancher/rancher (Go): affected from 2.6.7; fixed in 2.6.13
- github.com/rancher/rancher (Go): affected from 2.7.0; fixed in 2.7.4
- github.com/rancher/rancher (Go): affected from 2.7.0; fixed in 2.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22648/ (Markdown: https://insights.sbomify.com/CVE-2023-22648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22648
- OSV: https://osv.dev/vulnerability/CVE-2023-22648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22648/
Summaries are generated and may contain mistakes; the official description above is the record.
