{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22652 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2023-22652 is a low-severity memory corruption vulnerability in openSUSE libeconf, published on 1 Jun 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-22652 and fix it if it is affected.\n\nWhat it is: CVE-2023-22652 is a low-severity memory corruption vulnerability in openSUSE libeconf, published on 1 Jun 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22652 exists.\n\nAffected product: openSUSE libeconf. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-22652/ (Markdown: https://insights.sbomify.com/CVE-2023-22652/index.md)","id":"CVE-2023-22652","markdown":"https://insights.sbomify.com/CVE-2023-22652/index.md","name":"CVE-2023-22652","record":{"aliases":["ALSA-2023:4347","BELL-CVE-2023-22652","CVE-2023-30079","DEBIAN-CVE-2023-22652","DLA-4164-1","GHSA-rgj6-mpw9-qm58","UBUNTU-CVE-2023-22652","USN-8368-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"libeconf library","requires_auth":"none","summary":"A stack buffer overflow in libeconf allows attackers to cause a denial of service via malformed configuration files.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"libeconf","vendor":"opensuse"}],"cvss":{"score":3.3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"A Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') vulnerability in openSUSE libeconf leads to DoS via malformed config files.\nThis issue affects libeconf: before 0.5.2.","ecosystems":["AlmaLinux:9"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Stack buffer overflow in \"read_file\" function","id":"CVE-2023-22652","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2023"},"n_packages":1,"n_references":5,"next":{"headline":"Command injection in UR32L","id":"CVE-2023-22653"},"packages":[{"ecosystem":"AlmaLinux:9","fixed":["0.4.1-3.el9_2"],"introduced":["0"],"last_affected":[],"package":"libeconf","purl":"pkg:rpm/almalinux/libeconf","source":"ALSA-2023:4347"}],"prev":{"headline":"Rancher Webhook is misconfigured during upgrade process","id":"CVE-2023-22651"},"products":["libeconf"],"published":"2023-06-01","related":[{"cvss_score":3.3,"headline":"Stack buffer overflow in \"econf_writeFile\" function","id":"CVE-2023-32181","kev_date_added":null,"published":"2023-06-01"}],"sources":[{"class":"attribution","licence":"MIT","name":"AlmaLinux","prefix":"ALSA"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-13","vendors":["openSUSE"]},"summary":"A stack buffer overflow in libeconf allows attackers to cause a denial of service via malformed configuration files.","url":"https://insights.sbomify.com/CVE-2023-22652/"}