# CVE-2023-22665: Apache Jena: Exposure of arbitrary execution in script engine expressions.

> Remote attackers can execute arbitrary JavaScript via SPARQL queries due to insufficient input validation in Apache Jena script engine expressions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Apr 2023
- **Updated:** 13 Feb 2025
- **Also known as:** DEBIAN-CVE-2023-22665, GHSA-xgh5-gwq5-rpx8, UBUNTU-CVE-2023-22665

## What is CVE-2023-22665?

CVE-2023-22665 is a medium-severity code injection vulnerability in Apache Jena, published on 25 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement)

## Which versions are affected by CVE-2023-22665?

2 open source packages ship an affected version, including org.apache.jena:jena. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.jena:jena` | Maven | All versions | 4.8.0 |
| `org.apache.jena:jena` | Maven | All versions | 4.8.0 |

Products: Apache Jena.

## How do I fix CVE-2023-22665?

Upgrade org.apache.jena:jena to 4.8.0 or later.

## Is CVE-2023-22665 being exploited?

There is no known exploitation of CVE-2023-22665 in the wild and no public exploit code.

## Other vulnerabilities in Apache Jena

- [CVE-2022-28890](https://insights.sbomify.com/CVE-2022-28890/): Processing external DTDs (critical 9.8)
- [CVE-2025-50151](https://insights.sbomify.com/CVE-2025-50151/): Apache Jena: Configuration files uploaded by administrative users are not check properly (high 8.8)
- [CVE-2023-32200](https://insights.sbomify.com/CVE-2023-32200/): Apache Jena: Exposure of execution in script engine expressions. (high 8.8)
- [CVE-2025-49656](https://insights.sbomify.com/CVE-2025-49656/): Apache Jena: Administrative users can create files outside the server directory space via the admin UI (high 7.5)
- [CVE-2021-39239](https://insights.sbomify.com/CVE-2021-39239/): XML External Entity (XXE) vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22665 and fix it if it is affected.

What it is: CVE-2023-22665 is a medium-severity code injection vulnerability in Apache Jena, published on 25 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-22665 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.jena:jena (Maven): affected all versions; fixed in 4.8.0
- org.apache.jena:jena (Maven): affected all versions; fixed in 4.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22665/ (Markdown: https://insights.sbomify.com/CVE-2023-22665/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22665
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22665
- OSV: https://osv.dev/vulnerability/CVE-2023-22665

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22665/
Summaries are generated and may contain mistakes; the official description above is the record.
