CVE-2023-22722 glpi subject to Cross-site Scripting (XSS) - Reflected

Medium 6.8 Published Updated

Attackers can execute scripts in victim browsers via crafted URLs, leading to session hijacking or unauthorized actions in GLPI.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2023-22722?

CVE-2023-22722 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 25 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GLPI is a Free Asset and IT Management Software package. Versions 9.4.0 and above, prior to 10.0.6 are subject to Cross-site Scripting. An attacker can persuade a victim into opening a URL containing a payload exploiting this vulnerability. After exploited, the attacker can make actions as the victim or exfiltrate session cookies. This issue is patched in version 10.0.6.

Weakness: CWE-79

Which versions are affected by CVE-2023-22722?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2023-22722?

No fix has been published for CVE-2023-22722 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-22722 being exploited?

There is no known exploitation of CVE-2023-22722 in the wild and no public exploit code.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-352j-wr38-493c, UBUNTU-CVE-2023-22722.

Is CVE-2023-22722 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free