# CVE-2023-22728: Silverstripe Framework has missing permission check of canView in GridFieldPrintButton

> A missing permission check in Silverstripe's GridFieldPrintButton allows unauthorized content authors to view restricted records.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Apr 2023
- **Updated:** 31 Jan 2025
- **Also known as:** GHSA-jh3w-6jp2-vqqm

## What is CVE-2023-22728?

CVE-2023-22728 is a medium-severity missing authorization vulnerability in silverstripe-framework, published on 26 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Silverstripe Framework is the Model-View-Controller framework that powers the Silverstripe content management system. Prior to version 4.12.15, the GridField print view incorrectly validates the permission of DataObjects potentially allowing a content author to view records they are not authorised to access. Users should upgrade to Silverstripe Framework 4.12.15 or above to address the issue.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-22728?

2 open source packages ship an affected version, including silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | All versions | 4.12.5 |
| `silverstripe/framework` | Packagist | All versions | 4.12.5 |

Products: Silverstripe Framework.

## How do I fix CVE-2023-22728?

Upgrade silverstripe/framework to 4.12.5 or later.

## Is CVE-2023-22728 being exploited?

There is no known exploitation of CVE-2023-22728 in the wild and no public exploit code.

## Other vulnerabilities in silverstripe-framework

- [CVE-2022-38148](https://insights.sbomify.com/CVE-2022-38148/): Blind SQL Injection via GridFieldSortableHeader (high 8.8)
- [CVE-2022-38462](https://insights.sbomify.com/CVE-2022-38462/): Reflected XSS in querystring parameters (medium 6.1)
- [CVE-2025-30148](https://insights.sbomify.com/CVE-2025-30148/): Silverstripe Framework has a XSS vulnerability in HTML editor (medium 5.4)
- [CVE-2024-53277](https://insights.sbomify.com/CVE-2024-53277/): Cross-site Scripting in form messages in silverstripe framework (medium 5.4)
- [CVE-2024-32981](https://insights.sbomify.com/CVE-2024-32981/): Cross-site Scripting vulnerability with encoded payload in silverstripe/framework (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22728 and fix it if it is affected.

What it is: CVE-2023-22728 is a medium-severity missing authorization vulnerability in silverstripe-framework, published on 26 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22728 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected all versions; fixed in 4.12.5
- silverstripe/framework (Packagist): affected all versions; fixed in 4.12.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22728/ (Markdown: https://insights.sbomify.com/CVE-2023-22728/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22728
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22728
- OSV: https://osv.dev/vulnerability/CVE-2023-22728

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22728/
Summaries are generated and may contain mistakes; the official description above is the record.
